XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : particle render export bug?

11-26-2009, 12:57 AM

It seems to me that there is a namespace issue going on during export of particles. It appears that if you have two particles that share the same shape name, then only the first encountered shape name will be exported (to mental ray). I suspect, then, that this is also the reason why you can't render/export instances of particle objects (Maya Render screws fails on instances here too)?

Pretty annoying, when naming conventions are important (that is, when you really dont want to let every shape have a unique, and creation time dependent [arbitrary], name).

This is the case for both 2009 & 10.

Anyone know work arounds for this, bar wholesale renaming (and in instances case, not using instances)?


11-26-2009, 01:14 AM
I should add, this is for S/W render types (despite mental ray being able to render the classically H/W types... which, it has no problems exporting as instances, but not for independent same-named shapes..., but always problem for S/W types.).

11-26-2009, 03:11 AM
rename the particle as particle1 and particle2. This would help.

11-26-2009, 05:21 AM
sure, it would help (fix it even, in the case of indep. particle objs), however: '...bar wholesale renaming', meaning, a solution that does not resort to renaming all particles in the scene uniquely.

11-28-2009, 12:56 AM
This particle namespace pathing issue seems to have other manifestations too, outside of rendering. Eg in scripted particle expressions. User beware. Is this simply because some of the particle implementation code failed to use absolute pathing?

CGTalk Moderation
11-28-2009, 12:56 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.