View Full Version : Error with Sprite Wizard

11 November 2009, 07:50 PM
I have a simple particle setup where particle snow falls to the ground. These particles are sprites and the images for the sprites are 5 different snow flakes.

Initially i created the setup within a fresh scene with no problems. I opened the sprite wizard and assigned the 5 different images for the sprites and it simulated and rendered as expected. When the simulation was ready I imported it to the main scene with the rest of the project but i noticed that the sprites where only referencing one of the five images. I selected the particles and opened the sprite wizard reselected the first image and set it to 1 to 5 so it references all of them. When I click Apply i get the following error:

// Warning: Texture file F:/X/MAYA/X/sourceimages/Snow Sprites/Snow.01.tif doesn't exist, node snowEmitterExport_snowEmitterExport_file1 //

Doesnt exist? I can see that it does... weird.. :surprised

Even though it gives me this error it does assign ONE of the images to the sprites and even renders correctly..

Any ideas what could be causing this..?


11 November 2009, 08:20 PM
Although I don't use the sprite wizard, I do often get this very same error when I set up my own sprites. It is so frustrating because you can point it directly to an image and it will say it doesn't exist. Even if it's just a single image. I also often can't get the images to display at all after I get this error.

11 November 2009, 08:27 PM
I usually change the image format to tga or iff. It has nothing to do with the image formats because it will do it for all of them, but whatever one it does it to seems if you switch it it comes back...for a while at least. I have had it in some cases where I just decided to do the effect a different way because of this persistent problem. It is one of the most frustrating things I have encountered in Maya.

11 November 2009, 08:28 PM
any alternative ways to set it up?

im having the same problem with TGAs and PNGs


11 November 2009, 09:38 PM
strangest thing happened.. I created a particle cache and that solved the problem.. :thumbsup:

This is typical maya behavior...


11 November 2009, 01:29 AM
It's the naming convention for your sprites when using the Sprite Wizard. There can only be one period in your file names - so try using myFile001.tga instead of myFile.001.tga.

11 November 2009, 03:08 AM
Make sure your image is rgb . If it is in grayScale [Black and white] ,Maya has some trouble to read it.
It might help you

CGTalk Moderation
11 November 2009, 03:08 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.