View Full Version : Render Managers

08 August 2009, 01:37 AM
I need a render manager on my Mac OS X which will help me submit multiple files (so that by the time i come back from a walk.. my renders would be done)

I tried Smedge 3 .. but it gives me an Unlicensed Error in the Status (and i thought it was free)

I dotn know how to use drqueue

Either way if anyone know of any good render manager do let me know ..


08 August 2009, 02:06 AM
I couldn't get Smedge working either. Frantic Deadline works in OS X really well. I'm using it constantly right now. It's free for up to two slave machines - grab it from their site:

You'll also need the mono framework for it to run. Install that first.

There are a couple issues with the install that need fixing (the devs are aware of it and these fixes are coming in the next version):

- change the permissions of the Deadline Repository directory (and all sub directories) to allow you to have write access or it won't work. If you need help with this, say so.
- make sure to set the Maya build option to None in the job submit options or it will choke. I've modded the python submission script to have this on by default. Change the system checking portion of the SubmitMayaToDeadline.mel file to this:

if( $mayaBuildEnabled )
if( `about -is64` )
optionMenuGrp -e -select (3) $mentalRayBuildBox;
optionMenuGrp -e -select (1) $mentalRayBuildBox;
optionMenuGrp -e -select (1) $mentalRayBuildBox;

That just picks none by default instead of 32-bit.

08 August 2009, 11:09 AM
I changed permissions et stuff but when I run the render slave it gives me this error

and when I try to submit a job.. it doesnt happen.. probably because there arent any slaves.. I also checked the use local checkbox

still nothing any idea whats happening?


08 August 2009, 05:19 PM
you're still getting Deadline Repository permissions errors. Make sure you do this:

- Select Get Info in the Finder on the Deadline Repository folder
- In Sharing and Permissions, add your user and give youself Read & Write permissions
- under the gear icon, select apply to enclosed items

08 August 2009, 05:21 PM
and restart the Slave and then Maya to be sure. Sometimes I have seen that if the Slave isn't running when Maya launches, jobs aren't submitted properly

08 August 2009, 01:53 AM
Has anyone used Alfred as a management system? Now that RenderMan Studio is much more available to individuals I have been thinking about looking into it.

08 August 2009, 02:10 AM
hey Dave ..
thanks for the tips .. although the funny thing now is if i submit the file from within maya with the script.. then it tells me to export the mental ray files which calculates each and every frame and the size goes upto 5 gigs for 200 frames.. (Each layer)
If I try submitting it from the monitor.. it accepts the file, but only Queue's it.. doesnt render..

Andrew.. havent tried alfred yet.. but might give it a shot if nothing works out :)

08 August 2009, 04:38 AM
submit it as a maya render, not a mental ray standalone job. ie: the tab at the bottom left.

CGTalk Moderation
08 August 2009, 04:38 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.