View Full Version : mapped transparency vs parti_volume (Maya 09)

07 July 2009, 09:44 AM
Im experiencing these problems when using partivolume shader>

Any ideas guys??

Another issue is whenever my render camera go inside a volume (geometry with assigned parti_volume shader) it simply dissapear from rendered pics! So I ended up parenting the volume box in front of my cam so it never goes inside the volume. Silly but works for now.

If anybody got solutions for these issues I would be very grateful!



07 July 2009, 09:29 PM
I have a thought....:lightbulb

switch your shadow type to segments instead of simple or sorted. That should do it. Try also turning off the texture filters on the file texture node.

as for the partivolume camera can turn on "auto Volume" in the mr render settings. That will keep the volume from dissappearing when the camera enters the volume.

07 July 2009, 07:20 AM
Thanks for your input!

Well, I already switched the shadow type to segments (as far as I know they are intended to do volumetric shadowing).

Im afraid turning off filtering is not a way for me because of aliasing artifacts etc (close shots pixelation, moire patterns in full shot camera moves).

Regarding the AutoVolume option Ill try it asap so thanks for this tip!

Anybody any other idea??

Thanks pals!


07 July 2009, 08:02 AM
Those black outlines on cutout edges... Do you have black background on cutted out areas on texture? That may be the cause.

07 July 2009, 09:31 AM
Thanks for your input guys,

I finally resolved the problems! First autovolume works flawlessly (I do not understand why its turned off by default in maya render globals)

second It was filtering issue in texture > as you said turning filtering off helped (it even do not cause artifact when animated > no jaggies or moire)

Here is my final test (mia_material_x , cutout map without any filtering in file node)

Thanks again for your interest!


CGTalk Moderation
07 July 2009, 09:31 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.