View Full Version : bolean problem

07 July 2003, 08:45 PM
the problem with pic here
please help

07 July 2003, 08:59 PM
You should describe your problem better. Cause I can't see what's going on with that pic.

Anyway booleans often don't work as well as they should. Try to do it part by part if you are substracting many different parts (in one layer) from another layer. I mean, move those parts to one layer each. If that doesn't work try a walkarround that doesn't involve booleans.


07 July 2003, 09:01 PM
i think this pic will help
this is apic before bolean

07 July 2003, 09:06 PM
Yep, I see it now.

Try to do it one at a time, that's all I can say.


07 July 2003, 09:37 PM
i did it one by one
also crazy results
what to do?

07 July 2003, 09:40 PM
Are all of the points for each of the object's layers merged? It looks like you have a split mesh that you're trying to boolean and Modeler thinks what's out is in and what's in is out.

07 July 2003, 09:47 PM
i merged points in every layer but also same reult
:cry: :banghead:

07 July 2003, 10:05 PM
I have never had any realy unsolveable problems with LWs booleans, one just needs to check for a few things:
1. Make sure there are no nonplanar polygons in the objects.
2. Make sure there are no 1 and 2- point- polygons in the obejcts.
3. Make sure there are no 0- polygon- points in the objects.
4. Try selecting those parts of the geometry that the Boolean operation will have an effect on and see if it helps.
6. I usually bool everything at once, usually LW can better determine how to arrange the new geometry then.
7. If nothing helps try this: The boolean Add has always been working for me, so Add the BG- geometry and remove those polygons that you do not want (giving the BG- object a different surface helps with that).

Hope that helps

07 July 2003, 11:03 PM
i tried to do it with simble discs
also crazy results
what can i do
i think this is agreat bug
cause i was using max before and the boolean operation is very easy ther
i think there is some wrong with my modeler
if not
what to do
i am so frustrated

07 July 2003, 11:18 PM
the tutorial are there in 3d-palce .com
the man do it so easy there
what is the damn problem with my lightwave
could someone do it and tell me his result

07 July 2003, 11:54 PM
i tried to do it with drill or solid drill
also same results

07 July 2003, 12:43 AM
I had a same error with something I was trying to boolean.
Believe me, I feel your fustration. :banghead:

But I'm sorry I can't help, because the thing I was working on was completely different. And I finally figure out a way around it.

Sorry I couldn't help, but I just thought I'd let you know you're not alone. :surprised

07 July 2003, 12:48 AM
Originally posted by tejani
i tried to do it with drill or solid drill
also same results

Any chance you could post up your object file? Then we could have a go at reproducing your problem and hopefully figure it out.

Steve Warner
07 July 2003, 01:16 AM
Well, here is the basic process:

I got my background objects into place by positioning the first one at the bottom, mirroring it to the top, then copying and rotating those 90-degrees. That gave me one on the top, bottom, left and right. I then copied those, pasted them back and rotated them 45-degrees. You mentioned in your post on 3D-Palace that you were using the Array tool. Try doing the copy/mirror steps I mentioned and then Boolean again. The Array and especially the Radial Array tool can give problematic results when used with the Boolean tool.

07 July 2003, 01:35 AM
Tejani, if you were to select just one polygon and press the "]" key, does it select all the polygons of the big, round object you're trying to subtract from? If it doesn't, then your object isn't closed, and for some reason, something got shifted so that your merging points won't help.

I swear this looks like the error you get when you don't have a closed object.

07 July 2003, 01:38 AM

This is just a guess really as i was not able to recreate the problem that you are having. Try adding some extra polys with bandsaw on the flat area of the disk that you would like to boolean. The extra geometry may allow for the boolean operation to calculate the new geometry better. Like i said its just a guess though.

07 July 2003, 02:03 AM
thank u steve for your method
but i wonder in the tutorial the man do it so easily
at last this is my project file
see it and tell me what is wrong with it

Steve Warner
07 July 2003, 02:21 AM
Tejani, you're welcome!

Ok, here's what I think is happening. Your background object uses objects with a fairly high point count. I think that's causing the boolean operation to produce bad results. I rebult the background object using fewer points, did a radial array, then a boolean, and it worked. I did have to manually cut away some residual polys by hand, but it did work:

Here's the revised object file for you to try out:

Revised Cap Object (

Hope this helps!


07 July 2003, 02:29 AM
Unfortunately the problem with some tutorials is, that it looks so easy, but there is a lot of implied knowledge involved which can't be seen...

07 July 2003, 03:15 AM
thank u steve how could u make the back ground object like that
your object when i choose the top object of it and press]
it is all choosen but my objct not
how can i make it like yours
and thanks again

07 July 2003, 03:29 AM
thank u very much steve i got it at last
i used the knife tool to make the background object
and finally i made it:beer:
than u people
you helped me alot and learned me more
hope that thread learn newbies like me alot
alot of thanks

Steve Warner
07 July 2003, 03:42 AM
Excellent! :thumbsup: And you're welcome. Glad I could help. :wavey:



CGTalk Moderation
01 January 2006, 05:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.