View Full Version : mentalray slaves die before rendering

05 May 2009, 05:24 AM
Hello ;)

I have a little problem with some computers I someone wants to setup. I have 8 computers, 7 running windows xp and 1 running vista. I installed the raysat 2009 on every machine, setup the rayhosts file and all that jazz, and when I tried to render out something, I got a message saying "SLAVE 1 DIED"

I disabled the windows firewall on every machine, and also the antivirus firewall (panda AV). Tried again, nothing.

I can ping every computer with no problem, so I am certain it's not a network problem.

The other guy told me we should try all the computers one by one, so I edited the rayhosts file to disable all slaves except one. I did that for every machine, and the only one that didn't reject the MR connection was the one running Vista. All of the XP computers die soon after I hit the render button (it doesn't even finish the maya-to-mentalray translation or whatever).

In some forum I found some guy mentioned that updating the network card drivers could solve the problem, which is something I haven't done yet since those are not my machihnes and I can't mess with them at will.

So I was wondering if somebody has had this problem before, if I should update the drivers or look for something different?

Thanks :)

05 May 2009, 09:11 AM
Did you update the system32\drivers\etc\services file for each slave per the documentation?

Is the raysat server up and running on all machines?

05 May 2009, 11:51 AM
yep, it is. The service is running on every machine. I also checked the file you mention to make sure I was trying to connect to the correct port number.

05 May 2009, 07:00 PM
This may seem like an obvious suggestion, but do you have the correct version of mr satellite installed? There's been 2 service packs released since March and I can see how it might be easy to miss one.

05 May 2009, 07:42 PM
Well to tell the truth I don't know. As I said, those are not my machines, so maybe they have already installed the Service packs. As for the satellite installer, I used the one that comes with the Maya 2009 DVD, but the Maya 2009 had been previously installed on the "server" machine.

So maybe it's a good idea to check those service packs out. Maybe that's the problem.

BTW I just remembered the machine I was trying to use as a server had both Maya 2008 and 09, although I don't see why that should be a problem :-/

05 May 2009, 07:59 PM
Good idea to check. To my knowledge the master and slaves must have the same version of mental ray installed. The latest 2009 is SP 1a, so mental ray satellite must also be the latest, I'm not sure if it also has the suffix 1a. But yes, if you try to run Maya 2008 and the slaves have satellite from the 2009 DVD it will not work.

CGTalk Moderation
05 May 2009, 07:59 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.