View Full Version : Max 2010: <netManager>.GetServers gives error

04 April 2009, 01:14 PM
I have a render pass manager tool I wrote that I've been using for the past two Max versions, which now errors when I try to use it in Max 2010. I think I've found the specific issue. If you type this into the listener:

netMan.connect #automatic ""

Everything works fine up to this point. But if you then try to get a list of the servers by running this:


It then gives a ** system exception ** error.

This only happens in max 2010.

Any ideas?

04 April 2009, 01:37 PM
Hi Jon,

I've tried my code and I'be tried your code and i cannot re-produce the error.

netMan.connect #automatic ""
#(<MixinInterface:NetServer>, <MixinInterface:NetServer>)

can you think of anything else that might be causing it?


04 April 2009, 01:57 PM
Unfortunately I can't. I get the same error on two different machines, one on Vista and one on XP. They're both on the same network.Thanks though.

04 April 2009, 11:27 PM
just a thought: have you updated backburner on all render nodes?

04 April 2009, 11:59 PM

Yeah, I tried reinstalling BB on all the nodes (I have three on the render farm), and still, when I try this code on any of the three, they all give the same error. Two are Vista, one is XP. Two are production machines with lots of various software loaded, but the other is a bare-bones render-only machine, with only the OS installed, plus Max of course. The only thing they all have in common is they they share the same network, and they all run this code correctly with previous versions of Max but not with Max 2010.

This is very frustrating, as my whole render pipeline is dependent on this code working properly. Something is definately working different under the hood in Max 2010.

04 April 2009, 02:31 PM
i guess 2010 is out in the US and not in the uk? my sub center still lists 2009 as the only available.

[edit] ah, sorry, just checked the other forum, tend not to look at that one anymore! :hmm: nice to see the usual UI moans that accompany each release! :P

04 April 2009, 03:44 PM
Have you tried supplying a platform? The Platform (#32,#64,#default) parameter tells it how to connect to the manager, as either 32bit or 64bit (NOTE: you can only connect one at a time, so your results will either be 32bit or 64bit).


04 April 2009, 04:05 PM
That was a great idea, Eric, but unfortunately that didn't do it either.

04 April 2009, 05:42 PM
Doh, sorry I haven't deployed 2010 here, yet, so can't help with out just coming up with ideas. :/


04 April 2009, 04:03 PM
I posted this issue at forums, and I got a good fast response from Chris Johnson.

I'm hoping this will be fixed with the next hotfix that rolls out.

Thanks all.

CGTalk Moderation
04 April 2009, 04:03 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.