View Full Version : Error: ... goToConnectedMenuItem


ronviers
03 March 2009, 12:06 AM
If I select several nurbs curves and execute this:


string $selectedShapes[]=`ls -g -dag -sl`;
int $numCurves=`size $selectedShapes`-1;
for ($i=0;$i<$numCurves;$i++)
{
string $pociName=`createNode pointOnCurveInfo -n ("curve"+($i)+"_poci")`;
connectAttr -f ($selectedShapes[$i]+".worldSpace[0]") ($pociName+".inputCurve");
}


It works but I get this error message.

// Error: Object not found: goToConnectedMenuItem //

Does anyone else get that message too? Does anyone know what it means?

Thanks,
Ron

mlefevre
03 March 2009, 09:37 AM
Hey,

Ah, I don't get an error, but if you are trying to create and connect a node to each curve in your selection, it may be easier using the for in loop.

string $selectedShapes[]=`ls -g -dag -sl`;
for ($eachCurve in $selectedShapes)
{
string $pociName= `createNode pointOnCurveInfo -n ($eachCurve + "_poci")`;
connectAttr -f ($eachCurve + ".worldSpace[0]") ($pociName + ".inputCurve");
}

-matt

ronviers
03 March 2009, 04:36 PM
Thanks for taking a look at it. I can execute the code now and not get the message - it just went away. Which probably means it will just come back, but oh well.
I considered the for in, but the last curve in the selection is the path for the other curves so it has to be treated differently.

CGTalk Moderation
03 March 2009, 04:36 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1