View Full Version : Z-Depth pass problem

02 February 2009, 08:21 PM

I have a general problem when using Z-Depth passes to create DOF. It is usually no problem to use a z-depth pass if I want the foreground objects to be sharp and in focus. The problem starts when I want it the other way around and foreground and background objects overlap. The foreground objects should be blurred while the background objects should be sharp and in focus. Now the problem is that the foreground objects have sharp edges although the objects themselves are blurred.
How can I fix that problem and what am I doing wrong?


02 February 2009, 02:49 AM
The only thing you can do is render them separately. Blur the foreground objects, then put them 'over' the background objects.

By rendering them together you're missing all the occluded information of the background objects that is required to perform this operation. Its just a limitation of trying to do all your DOF in post.

If you're going to do things like DOF and motion blur in your compositing application then you need to create your render layers based on this.

Hope this helps.

02 February 2009, 11:59 AM
you can use richard rosenmans DOF generator pro. You do'nt have that problem here... it is a PS filer though, but is has a batchrender option for imagesequences:D

02 February 2009, 11:51 PM
thanks, I already suspected that I have to render those objects seperatey. It kind of makes sense because there is no information behind the foreground objects if I render it in one pass.

I tried the dofpro plugin too but it doesn't do it perfect either. I still get some hard edges.

CGTalk Moderation
02 February 2009, 11:51 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.