View Full Version : HELP!! ZBrush very bizarre normal map issues

02 February 2009, 02:17 PM
Hi all-

I hope you can help me as this is driivng me insane! I'm working on a 3D model of a zombie covered in fungus. It's to be game optimised so has a low poly mesh of around 5000 quads.

I laid out the UV map and exported to Zbrush to sculpt up a high res version. However, when I try to generate the normal maps, ZMapper shows nothing and creates either a blank blue normal map with no detail at all, or a random mess of jagged slices of arefacting. If I use the ZBrush "normal map" palette, I get nothing again unless I enable adaptive and smoothUV- then I get the map attached. If you look at the two images (sorry for quality), one shows the UV layout, the other the normal map- the normal map has a curved "slice" of correct UV mapping, the the rest- nothing...if I try to generate the map in Maya (as per the 3D world tut this month) it gets to 99% generation then freezes up and crashes.

I originally modelled the head in Blender and laid out UVs in it, but since then I exported it into Maya and Maya is quite happy with it- and I exported it out of Maya as well to put in ZBrush, but this made no difference to the direct export from Blender to ZBrush.

I am using trial software so have a limited time to try to fix this- if anyone can help I would greatly appreciate it, as I have hours of sculpting done for this head, and was about to start the body too!

Thanks a lot

Russ (praxedes)

02 February 2009, 03:05 PM
did you do an UV check? Texture -> UV check in Zbrush and see if there's any red in the resulting texture. Sometimes the UVs get messed up when exporting.
obviously don't hit escape when it's generating the normal map because it somewhat looks like zmapper wasn't finished rendering the normal map.
what are your zmapper-settings?

you might be better off asking this on zbrushcentral though

02 February 2009, 04:58 PM
did you do an UV check?

hah- you are a genius :) When I checked, the ENTIRE model went red- when I looked in more detail, single tiny face from inside one nostril had been missed out of the unwrap, so was a square that filled the texture space. I couldn't see it without knowing it was there, but it overlapped all of the other UVs!

I think this means I need to redo my head sculpt onto a non-messed up base mesh now though :( That's five hours I won't see again!



02 February 2009, 09:52 PM
no you dont. you can either export the lowpoly, redo the UVs and insert the mesh, although i find this rather annoying since it occasionally gives errors or you can export the lowpoly, redo the UVs, import it again, open the ZTool with your sculpt, append the remapped lowpoly as a Subtool, divide it until it has aprox. the same amount of polys (or the same amount if you don't change the lowpoly), have the lowpoly subtool selected and press "project all". once it's done you can delete the highpoly with the screwed lowpoly and be left with the fixed lowpoly and the sculpted highpoly on it's higher subdivs.

hope that helps

02 February 2009, 09:49 AM
That's great, thanks!

I had discovered I could still project the normal map to the corrected Low poly UV layout in Maya but this means I can use ZMapper as well :)



02 February 2009, 09:37 AM
More problems again- and so far this thread has been my saviour so..

I reprojected as suggested, normal maps working fine. BUT I also want to project an AO map.


What I tried was setting the trasnfer maps up pretty much exactly as for normal mapping, but seitched to AO map and set the mental ray settings to give a reasonable quality AO pass and map.

What I end up with is either a pure white on black undetailed non aliased image that looks like an alpha of my UV layout, or at one point the repeated message in the MEL bar "//warning- nothing to bake"

What am I doing wrong? Note that currently there are no materials assigned to the this an issue? Do I need a render first? I am somewhat fristrated after getting the same result maybe 15 times now...

thnaks in advance, sorry to bug!


CGTalk Moderation
02 February 2009, 09:37 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.