View Full Version : No alpha on sprite shaders

06 June 2003, 08:23 AM

I cannot get the alpha channel to work from my sprite particles.
I am using a tga 32 bit file ( I checked in photoshop, the alpha channel is there) but no matter what I try I always get square sprites with solid black instead of transparent. I tried everything I could think of (alpha offset, alpha gain, plugin the sprite into the transparency of the lambert shader). Nothing seems to have an effect.
I am going cuckoo :surprised

06 June 2003, 06:50 AM
What graphics card are you using? I used to use a 3DLabs GVX1 and there were two settings: Maya and Maya with Alpha. I had to set it to the latter to get alphas to work.

06 June 2003, 09:31 PM
Thanks for you answer.
But I actually solved the problem. The original images were made in After Effects and even though Photoshop was seeing the alpha correctly Maya didn't. Resaving each image from Photoshop fixed the problem.

CGTalk Moderation
01 January 2006, 01:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.