View Full Version : where's the hair?

12 December 2008, 03:36 PM
seems max doesn't render hair if you call the render() command. What is the reason for that and how can i fix that problem? Is there something like a renderhair() command, i missed???

help appreciated


12 December 2008, 08:17 PM
which 3ds Max version?

In 3ds Max 2009x32:

mySphere = geosphere()
addModifier mySphere (HairMod())
result = render()

works just dandy :o

12 December 2008, 09:08 PM
I am using 3dsmax 9 32bit on win xp. A little out of date by now, but still really good. They have obviosly fixed that issue with newer versions. The exact same script gives me only a sphere.

anyone experienced with max9 ???


12 December 2008, 09:25 PM
just tried in max 9 - still work there as well.

Does it show up if you run...
max quick render

and what if you launch a render manually?

if you are using a third party renderer, are you perhaps supposed to pass it code to make it run through the render effects?

12 December 2008, 09:26 PM
Hair is a Render Effect. Did you verify that the Hair and Fur render effect was added and is active? Is it working fine with a regular press of the render button?


12 December 2008, 10:23 PM
hi. I am using scanline renderer and no plugins. If i start max add a sphere and apply the hair modifier i get perfect results doing a render or a quick render. The hair effect is active and obviously working. But the hair does not render (nor do the shadows) if i call render().

huh. i just tested mental ray and it worked. Switched back to scanline and suddenly it works there as well. Now i'm confused...

CGTalk Moderation
12 December 2008, 10:23 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.