View Full Version : Particles won't update/render

11 November 2008, 12:10 PM
please have a look at the attached file (max 2008) and scheme.
If I scrub the timeline forwards, it looks perfect.
If I render a single frame (with visible particles), things start to get nasty: the shape instance's animation is not respected (it is in the viewport).
After the rendering, it gets wrong in the viewport too, and I got to get back to frame 0 and scrub again to get things fixed.
Also, if I render the whole frame range, no particles are rendered, or it renders the ones present in the frame I was to when I launched the rendering.
Any hint?

11 November 2008, 12:17 PM
I can't look at the file at the moment, but I've had the same problem with a position object per vertex Birth Script. Maybe someone else can help with a solution.

11 November 2008, 12:47 PM
Have you tried a global cache?

11 November 2008, 12:52 PM
well, I don't know if/how I could use it, since the flow doesn't properly have an end, since it's looped. Anyway I tried to break the flow and put a cache op, but nothing again.

11 November 2008, 03:15 PM
It seems that the problem is in pflow not "seeing" that a vol. select modifier changes vertex selection every frame... hell. Any hint?

11 November 2008, 10:27 AM
Have you tried a global cache?
For anyone interested, this was a solution - I had simply to put it in the rendering operator. Thanks to Oleg (Orbaz technologies).

CGTalk Moderation
11 November 2008, 10:27 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.