View Full Version : mip_motionblur doesnt blur

11 November 2008, 12:58 AM
Hello everybody!

This might be a simple question but I somehow cant figure it out on my own:

I have a typical character setup:

- mia_physicalsky shader for the lighting (created with the button in the rendersettings dialog).
- a camera that renders an alpha background and environment reflections via mip_rayswitch_environment (connected to mip_mirroball and mib_color_alpha)
- a plane to catch the shadow of the object with mip_matteshadow (connected to mib_color_alpha as well)

It all renders well. To speed thinks up (a frame takes around 80 seconds to render with motionblur on preview settings) I tried to use mip_motionblur. But it just doesnt blur.

Here's what I did:

- created mip_motionblur and plugged it into the default channel of my camera. The connection reads "mip_motionblur1.message -> mainCameraShape.miOutputShader"
- set mentalray to:
"Shutter Open" and "Shutter Close" to 0.000,
"Time Samples" set to 1.
"Motion Blur" set to "Full".
"Primary Renderer" to "Scanline" (tried Rasterizer and Raytracing as well).
"Sec. Effects" to "Raytraycing", FG an GI.

Am I missing something?

I opened an example from MasterZap that works just fine. It seems to use the same setup except using the production library shaders for matte and environment. I just cant see the difference!

Thanks in advance!


11 November 2008, 01:31 AM
back again...

yup... I missed something...

Setting "Depth" and "Motion Vectors" Attribs in the Attribute Editor of your render camera under "mental ray=>Lens Shaders=>Primary Output Shaders=>Secondary Output Shaders" helps, mip_motionblur finally works.

I thought I did that, but did it for the wrong camera. Doh...

CGTalk Moderation
11 November 2008, 01:31 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.