View Full Version : Too much CPU usage?!

10 October 2008, 09:52 PM
I just wanted to ask the community if anyone out there with a quad core cpu is noticing xsi7 using too much processor while rendering.

for me, after making a few renders, i find that xsi uses all of my cores and leaves the OS no cpu power at all to do anything else. sound studders ( even with a dedicated sound card ), even my mouse studders like nuts. i found that the only solution was to subtract one cpu affinity from xsi.

anyone have this behaviour with quad cores?! because i dont remember getting this with my older P4 dual core system.

Zafar Iqbal
10 October 2008, 11:32 AM
I noticed the same thing when I tried the demo - you're not alone.

10 October 2008, 12:40 PM
it happens here, what i do is i lower the priorities in the task manager and i can use my mouse.. it gives the total render power when im not doing anything and if i need something else it lowers enough to let me do so

10 October 2008, 02:30 PM
Uhh, excuse me, but isn't that a good problem to have? That's like saying my race car goes too fast.

When you are rendering on a computer, don't expect to do anything else...or you can get another system to work on while the other renders.

I don't know why anyone would expect anything but maximum CPU usage when rendering.

10 October 2008, 04:30 PM
because you cant even move the mouse to stop the render if you realise that something is wrong o forgot to do something before hiting the button, is not like if you are going to be playing team fortres while you render... is just that you really cant do anything. and i dont think that moving my mouse is really really going to delay the overall render time.

Zafar Iqbal
10 October 2008, 05:50 PM
What barbapapa said - I've ended up having to spend/try for several minutes (didn't time it, but I'm guessing at least 5 minutes) to regain control, because the mouse was so laggy and the computer non-responsive. I remember it clearly because it was so severe and I've only experienced this while running the v7 demo.

Well, ok - not entirely true. I experienced it on P4 CPU's as well on a different 3D app some years ago too.

10 October 2008, 09:04 PM
Normally, the mouse movement should never be stuttering, no matter how buzye the CPU are. In my experience, this happens only when the operating system is swapping to disk. When that happens, Windows becomes unresponsible due to all the I/O interrupts.
So it would be a memory usage problem, not a CPU priority one. Check if your render is using more RAM than you have. Try using .map files for textures if you are not already

10 October 2008, 10:06 PM
I've maxed CPU's to 100% on my Quad when using XSI. Interestingly enough, I can still surf the web, listen to music etc. Not sure what's happening from your end, but there is not any noticeable lag launching other apps. This is on a Vista 64 machine.

10 October 2008, 02:05 AM
I had Bitdefender antivirus cause problems like this, but with multiple apps. I have no idea if this could be related, but getting rid of bitdefender solved all my problems. Good riddance to bad trash.

10 October 2008, 02:13 PM
I've maxed CPU's to 100% on my Quad when using XSI. Interestingly enough, I can still surf the web, listen to music etc. Not sure what's happening from your end, but there is not any noticeable lag launching other apps. This is on a Vista 64 machine.

Same here...

I'd say the problem with not being able to do even the most miniscule tasks while rendering is indicative of a system that may be great in the CPU department, but lacking in other areas. I can actually open up After Effects and do a little emergency work if I need to without stopping a render that's supposedly hogging 100% of the CPU.

I'm using Vista64, 8GB ram, quadcore q9450

10 October 2008, 02:46 PM
heres the thing

quad core 9550
8gb ram -6400(ocz reaper series ) ( im not maxing it out, im only using about 2gb within the scene )
asus p5q-ws
velociraptor 300gb.

theres no slow parts in there. hell, i even have a dedicated soundcard to take the load off while listening to music.

i am starting to think that its a system thing, but id love to hear from anyone that has had this issue, on how they resolved it. for now i am just turning off one core for xsi. thing is, i can do the same with cinema and its perfectly fine. it utilizes all cores as well.

10 October 2008, 07:46 PM
This is mentalray problem. on some scenes (materials?).

I didnt have this prob with XSI 7, only with 3ds max + MR/xsi6. And this is very annoying.

I saw somewhere @ xsibase guys with same prob, and they were changing priority of mr to low via task manager.

(dual xeon qcore / vista x64)

10 October 2008, 08:25 PM
I encountered a similar problem some time ago where it was caused by a faulty Nvidia driver (one of the first with OGL multithreading support). It caused the effect for 3DSmax and CINEMA 4D in slightly different ways, but reproduceable.


CGTalk Moderation
10 October 2008, 08:25 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.