XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : call me a dumbass but... can't get mentalray shaders to render

06-10-2003, 11:25 AM
Hiya really dumb question I guess. Following the MRFMaya docs, I create a sphere and a point light. I create a blinn shading group and in the mental ray section, I drag a mib_illum_* into the material slot. Then I render with mental ray and... I get all black.

If I turn the ambient and ambience up to white in the mib_illum_* then I get a pure white circle (unshaded sphere). I've tried adding a mib_light_* to the lightsource but it still doesn't work.

ANyone know why??

06-10-2003, 12:47 PM
I have another problem, maybe similar, with dgs_material on a sphere: it doesn't render! I have a black area, there's nothing there..not even in the alpha channel..
It used to work, so i'm puzzled, because i'm not doing anything different..

06-11-2003, 09:27 AM
What you need to do is connect the lights to the shaders.

Using the Connection Editor, connect the 'message' of the light to the 'lights' of the shader. That should do it.

06-11-2003, 11:34 PM
Woohoo! it works!!! cheers jozvex!!:beer:

For future reference, is this in the Maya docs somewhere?

Also, is there an automatic way of doing this? (aside from writing my own scripts for doing the connections)

thanks again!

06-12-2003, 03:56 AM
It's not in the docs to my knowledge. I discovered it because in the Mental Ray reference docs it says that most of these shaders have a 'lights' attribute. But it doesn't show up in the Attribute Editor, so I just tried making some connections and it worked!

And no, it seems to be a manual task at the moment. :surprised

06-12-2003, 08:22 AM
Anyone would think they really didn't want us to use mentalray shaders!

Ah well, on with the shader work! Thanks again.

CGTalk Moderation
01-15-2006, 10:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.