View Full Version : Motion Dump Process

09 September 2008, 05:20 AM
Hello all,

So I recently discovered the faults of the Messiah plugin connection to Lightwave (if that should no longer be used, pmg should really take it off of their website!), and I instead want to use the Motion Dump. But I've tried and tried and I can't get it working right.

I pose my model, select one of the meshes (like the shirt object), go to the Customize tab, go to Motion Dump, select Freeze, set it to World, and then Generate Motion. THen I go to Lightwave, load that same shirt obj, go to Load>Load Motion (while the shirt object is selected), and load the .mot I exported from Messiah. Keyframes show up in the timeline, but the shirt doesn't move to the pose I had it in in Messiah.

I've tried seeting the Displacement to last, I've tried it Subpatched and unsubpatched (in both Messiah and Lightwave), I've tried setting a key in Messiah before dumping...I've tried everyhting I can think of, and it won't move in Lightwave.

Can somebody perhaps list a step by step of dumping the motion from Messiah and importing it into Lightwave?

Thanks so much!

09 September 2008, 06:38 AM
.mot is only motion. If you load .mot for object, it move's the whole object, doesn't deform. Instead use .mdd, in messiah Customize tab select "SaveMorphSequence". In lightwave use deformer called mddplug or something like that, can't remember.

09 September 2008, 06:45 AM
The .mot files are used only to control motion (translation, rotation, scale). For example: camera motions or light motions. You're creating a posed (deformed) character. So what you want is the "SaveMorphSequence" selection under the Customize tab (same list you find 'MotionDump'). This will export a LW friendly .MDD file. Now back in LW load the object then select properties, deform tab, add displacement, select MD_Plug then point the plugin to your created MDD file. Set the deformation to last and you should be good to go.

For the record, you *can* still use Messiah as a LW plugin but it's a bit tricky now and these days the data flow is only one way: from Messiah to Lightwave. It's great to have the real time feedback for use with FPrime, etc. But in the end MDDs are going to be the best way once you have the finished product on the Messiah side.

09 September 2008, 04:26 PM
That's what I needed!


09 September 2008, 06:21 PM
From one issue to the next...

So the MDDs are working great...but here's the weird thing. Everything is working fine when *on Windows* I export the MDDs from Messiah and import them into Lightwave.

But when I try to either open that scene, or make a fresh one in Lightwave on Mac, it just keeps asking me to state where the MDD is, even after I've just located it and loaded it.

Any ideas as to why?

09 September 2008, 09:07 PM
Before you load the scene, press d and under paths "change" your content directory to the same directory that was there. Even though you got the right directory listed there you sometimes must select it again to avoid Layout asking you for MDD files. This has to do with the messiah master plugin loading every time when you start Layout. If you are not using messiah as a plugin you can delete this master plugin and everything should work fine.

09 September 2008, 11:38 PM
Thanks for the response. I still can't get it to work though. I'm on Mac, so there is no Messiah plugin installed, and even when I hand select the MDD, it still just asks me to locate it again. It's just a big loop. I tested the MDD in modo, and it works fine.

09 September 2008, 03:30 PM
Not sure if this will help... but here goes..

Have you tried to replicate the same folder structure that you have in Windows in your Mac environment?.. So, if the Mdd was in C:\project\mmd\xxx.. make the same path on Mac.

I'm wondering if there is something written into the mdd file that points to the folder..Also, from your post (below) it was not clear if you changed the content directory.. and if so, did you try closing LW afterwards.. maybe it is not seeing the change..

Since Modo works, it seems the mdd file is ok..

Thanks for the response. I still can't get it to work though. I'm on Mac, so there is no Messiah plugin installed, and even when I hand select the MDD, it still just asks me to locate it again. It's just a big loop. I tested the MDD in modo, and it works fine.

09 September 2008, 07:29 PM
I tried to replicate the folder structure best I could...I placed the content directory into Mactintosh HD, which as close to the root as possible, and the closest equivilent to C: as I can come up to. No dice, though.

I don't think it is a file system problem, though. Because the locations saved inside the LWS are relative, not absolute. I copied the same content directory over to my partner's PC (Windows), and it wasn't placed in the same place as on my Windows, and when he opened the scene, it loaded the MDDs just fine.

It seems like some error in the MDD itself associated with Lightwave on Mac. I don't know if it is a bug...and if there is anyway to fix it...

Any thoughts from those smarter than me?

09 September 2008, 08:53 PM
Okay, so I tested the MDD system in Lightwave Mac by exporting a MDD from Blender, and it imported and worked fine in Lightwave Mac. So I would assume that this is specifically a Messiah issue, in that the MDDs exported from Messiah won't open in Lightwave Mac.

09 September 2008, 06:27 AM
Have you tried other mdd readers for lightwave? Can't recall the names, I don't operate lightwave, but I know there are other plugs for this.

09 September 2008, 05:01 AM
I know that there is Point Oven...but it seems a little ridiculous to need to buy a completely separate plug in for something that's already built into Messiah. I hope I can find a fix for this...any help would be appreciated!


09 September 2008, 02:20 PM
Is it a problem for all mdds from messiah?

If you're working with lw 9.x I think there's a displacement node from dpont that reads mdd that might work. You could also try applying softFX to the mesh and loading the mdd there.

09 September 2008, 03:47 PM
It seems to be a Mac LW problem. I just tried it and neither a messiah-generated nor LW-generated MDD will load into Mac LW (version 9.3.1 anyway).


PS: We had massive server troubles at pmG this week, which is why I didn't get back to you from "Tech Support". Sorry about that.

09 September 2008, 05:19 PM
Thanks for the post Fred.

I think I figured it out...get this:

If you try to open the scene created on Windows Lightwave, then the slashes are wrong...they are "\" instead of "/".

In 9.3.1, if you try to add an MDD to an object on Mac Lightwave, it appends a "/" to the front of the path, which, if you have your content directory properly set up, messes up the path to the MDD.

So, in either case, switch all "\" to "/" and make sure there's no slash at the front of the path, and it should work.


Glad I figured it out though. Thanks for the help guys!

CGTalk Moderation
09 September 2008, 05:19 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.