View Full Version : normal map won't appear on model??


RThomson
08 August 2008, 12:23 AM
I desperately need help here, I've been trying for half a day now and nothing happens, whatever tutorial I follow has no results. I'm about ready to explode.

All I want to do is load my premade normal map, which works in another program, no problem, and stick it on my low poly model.

what I've tried.

1 - I imported my .obj model
2 - pressed f5 to go to texture settings.
3 - set 'map input' to 'uv' and 'map to' to only 'nor' (tried with and without creating new texture)
4 - pressed f6
5 - 'texture type' set to 'image'
6 - loaded normal map at far right
7 - in 'map image' tab, normal map is selected.
8 - tried creating a light, all types failed
9 - smoothed normals
10 - created a material, assigned the texture, named the object and texture the same thing, pulled at some more straws, tried rendering (that just gave me exactly what i was looking at in the 3d window but with a blue background)
11 - damned blender to hell..

et voila! a glorious nothing at all happens.


In the little preview box i can see a black and white preview of the map looking very normal mappy, but that's all i get.


http://i2.photobucket.com/albums/y10/Treborguy/settings.jpg http://i2.photobucket.com/albums/y10/Treborguy/previews.jpg

http://i2.photobucket.com/albums/y10/Treborguy/modes.jpg

proof that my normal map isn't screwed:

http://i2.photobucket.com/albums/y10/Treborguy/correct.jpg

If anyone can help that would be great,
a step by step of loading model and map to seeing them working together would be great.

i've burnt google out so please can people not refer me to the usual blender tutorials, they don't work for me.

thanks in advance

R!

Joat
08 August 2008, 01:23 AM
Your texture settings seem to be right. Also, your textured and shaded views as well as preview-views seem like would be expected. But you don't show us how it comes out rendered.

In shaded or textured view you can't see the normal map in full effect, unless you have Apricot build of Blender with GLSL shaders.

Try rendering us an example and we'll see what the problem is with the render.

edit: I read your post again and seems you have tried to render it to no avail. Please post screenshots of your texture pane and your render settings. Also, in the "map to" - pane, how much is your "Nor" - amount? It is one thing that affects the outcome. I suggest the value of 1.00 to start with. If the effect is nonexistent, try rising the value and if that doesnt help, lovering it.

At ->texture->image check you have the right image loaded, and you have "Normal Map" pressed at "Map image"- tab. I usually check also "Extend" insted of the default "Repeat".

I work from Blender to 3Dcoat and back myself, and the process is ont the most esay to get right. But once you find the settings that work for you, it becomes automatic.

Hang in there, you will solve it!

RThomson
08 August 2008, 01:49 AM
honestly, like I said, the rendered version looks exactly like whatever's in the 3d window, but with a different coloured background. there's not much point in showing you. but i didn't know about an apricot version. i'll have to check that out.

thanks for the response.

RThomson
08 August 2008, 02:04 AM
I already tried the nor settings and all that you have suggested, still nothing works.


hmm,
seems the quick render preview window does do something, and a lot of clicking buttons on and off has got me this:

http://i2.photobucket.com/albums/y10/Treborguy/eucghh.jpg


But it's still no use to me if it doesn't appear in the main window or render window and it has loads of really bad seams where the map splits up, like on the shoulders there :(


Joat: I have no idea about render settings, i wouldn't know where to begin showing you what i've got. are there any specific settings you know of that are required to render maps which aren't diffuse.

and yes, i hope I get it fixed :P

RThomson
08 August 2008, 12:29 PM
I almost figured it out. it turns out that blender doesn't seem to like tangent space normal maps, so I just converted it to an object space normal map using xnormal and changed the recommended normal settings.

oh and i figured out why rendering wasn't working, i was pressing the 'render this window 'button, not the big RENDER button :P d'oh!

I'm still getting (be it, smaller..) seams where my uv map splits on the model.

any ideas?
http://i2.photobucket.com/albums/y10/Treborguy/blech.jpg

Joat
08 August 2008, 12:11 AM
Looking better, good!

At ->texture->image check you have the right image loaded, and you have "Normal Map" pressed at "Map image"- tab. I usually check also "Extend" instead of the default "Repeat".

Did you try this already? Didi it do anything for the seams?

Michael-Williamson
08 August 2008, 11:36 AM
I've found that blender gets on fine with tangent space normals.

you'd be better sticking to the "tangent space" map if you intend on animating your model.

In that check of the materials-textures buttons? under the "map image" panel you make sure that "normal map" is selected and the type set to "tangent"? ( that's the default isn't it?)

if the normal maps are generated outside of blender (you're usind x normal?) you may need to invert one or more colour channels and/or swap the channels around. There's apparently not a common convention for which XYZ axis is mapped to RGB and which direction is positive or negative.. blender is z-up where as most aps use y-up.

Once you know the direction you'll be fine.

Easier still would be generating the normal map from inside blender by baking "selected to active". This way you know for sure that the normals are "right" for blender... you could compare an internal bake to your external map to help figure out the axis differences to get it right.

CGTalk Moderation
08 August 2008, 11:36 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1