View Full Version : Pflow - Final Step Update. Not Executing

06 June 2008, 04:01 PM
I've written a script to instance V-Ray proxies to the particles as a Final Step Update, but have found that there are times when the Script is not called.

1- When rendering a single frame.
2- First frame of a net rendered job.
3- If the a pickup frame is the same as current Slider Time...

I've tried "Bumping" the time to get the script to fire off, that works locally but not over the network. Any idea on how to ensure the Final Step happens everytime the renderer is invoked?


06 June 2008, 04:10 PM
Have you tried using Bobo's script that he posted here (


06 June 2008, 04:32 PM
Thanks for the link, but that create's instances in the local file and key frames them. I'm actually working with a static Pflow ( massive landscaping with plant variances. ) I wished to have just the Pflow in the file on submission and have the Pflow take care of itself.
I'll most likely write a #preRender or #postFileOpen to achieve this, as the Final Step has this issue of needing the time to change in order to execute...

CGTalk Moderation
06 June 2008, 04:32 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.