View Full Version : shift+enter stopped working

05 May 2008, 05:03 PM

I'm puzzled: Evaluating a textblock with shift+enter stopped working after a while. Is it a bug or have i pressed a keyboard shortcut deactivating Maxscripts ability to evaluate (Max has some of these evil buttons to frustrate newbees like X to hide the gizmo, O to switch into adaptive degradation, space to lock the current selection...arg). However, everything is back to normal after a restarting Max. but since this problem keeps coming up, restarting is no good solution.


05 May 2008, 06:22 PM
It's just a guess, but it can happen that MaxScript is still struggling with the code you have evaluated before. Hitting the [ESC] key while being in the listener could solve the problem, if you haven't tried already. This will interrupt whatever is/was running. (correct me if I'm wrong here)

05 May 2008, 01:28 AM
this can also happen if you have an unclosed paranthesis or unclosed quote somewhere.


fn myTest something = (
print "go something -- note missing close quotation mark

You can hit shift-enter on anything later all you want, but without closing that string with a quotation mark, maxscript will just sit there thinking you're adding to the string.

It can be quite evil.. I usually end up writing a bunch of ")") and try to evaluate those a few times. If it never comes back to life, restarting max it is.

05 May 2008, 03:25 AM
Yeah I normally end up restarting max when that happens.

05 May 2008, 08:06 AM
this can also happen if you have an unclosed paranthesis or unclosed quote somewhere.

thanks a lot. This information was extremely helpful. Something like this must have happened. Really great to know that evaluating ") can help.

05 May 2008, 12:58 PM
Really great to know that evaluating ") can help.
It can, or it can make matters worse.

For example, if you're not missing a lacking ", but missing a lacking ) instead... then by evaluating ") you're actually opening a new string. So now you have a lacking ) (the original problem) -and- a new lacking " :)

9/10 times, hitting Esc should work and give you an ** interrupted **

05 May 2008, 01:58 PM
wow. I didn't know that. Whenever something is not working i try escape, only this time i did not. I simply did not think of it. I thank you very much. restarting max was a pain in the...

06 June 2008, 10:58 PM
My problem deals with shift, the gizmo, and the edge selection. I am following a tutorial which is asking me to click the edge of a plane, already having the gizmo selected, then I hold shift and drag any which way. When I do this, my gizmo disapears and the edge deselects. I dont know why this is. Just for a test, I put a plane off my image, to test and see if it does it to the overall file, but it worked for the plane not part of my model. Every edge on my model does this, and im curious as to why, cause I really need to figure this out.

Thanks guys :)

06 June 2008, 10:26 AM
haha. this is not exactly related to the original topic...

anyhow. I do know the solution. You must select an open edge for shift-extrude to work. If the edge has polygons on both sides it can't be extruded using this technique. So go ahead and delete one poly and you will find it working.


CGTalk Moderation
06 June 2008, 10:26 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.