View Full Version : particle cache bug in EX2?

05 May 2008, 06:24 PM
is anyone eles seen this or am I doing something wrong?

I have a particle system that I setup nothing just some particles flowing down through a tube. I created a cache and I can scrub the timeline and play the particles backwards and forwards. All appears to be well but when I batch render them I get noe particle motion at all. The particles just sit there at their initial state.

If someone can tell me what is going on here I would apprciate it I have to get this project turned in ASAP and this is the last element I have to render.

05 May 2008, 12:12 AM
Are you rendering locally or in a distributed environment?

What operating system are you using?

Is this a simple emitter setup or are you using curveFlow or the like?

05 May 2008, 06:15 AM
do' nt know if your hardware or software rendering........

but I had this problem with 2008 and mental ray ... try checking Export Full Dagpath in the Translation section of the render globals worked for me



05 May 2008, 01:30 PM
I noticed a wierd problem (2008 sp1) where if the particleShape start time was set to frame 10, and then I cached frames 1 to 100, then I would get no particles if I rendered from frame 1 onwards (I mean even after it got past frame 10, still no particles), but it worked ok if I rendered from frame 10 onwards. I just had to set the particle start frame to frame 1 and recache to fix the problem.

05 May 2008, 02:53 PM
Ok I just don't get this I create the cache and I an can scrub backwards and forwards and have perfect motion in my particles. I can render frames in may aand they look exactly as they should but If I batch render from within maya, outside of maya or submit it to the farm I get renders but there is no motion at all.

note: particles are set to sphere and rendering is using mental ray.

05 May 2008, 03:50 PM
Ok it gets wierder upon further examination it seems that the the particles animate until the camera comes to a stop and then all motion stops. Man this is sooo frustrating.

05 May 2008, 07:31 PM
Anyway after more study it seems that the issue is directly related to Mental ray's rendering of Hardware particles. there seems to be some sort of bug. Because if I use same scene and set the renderer to HW and then batch it I get motion using the same cache. Nothing has changed. But it I use Mental ray it renders the particles for every frame but there is no animation on any frame where the camera is not moving. on frames where the camera is moving the particles will animate.

CGTalk Moderation
05 May 2008, 07:31 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.