View Full Version : Strange After Effects' Import problem with EI's PSDs (Mac)

04 April 2008, 01:44 AM
I am having an odd problem with EI's Shader Layer's Photoshop output and AE CS3's import abilities: I have produced a Shader Layer-generated sequence of PSD files. I can drop these files into AE's Project pane or the app's icon, and it will happily produce the corresponding compositions. It won't recognize these same files via the Import file dialog, even if I select the All files option: they appear grayed out.

These were rendered via Renderama. I did a small test with the same project, rendering frames with network rendering disabled: AE sees them OK and allows me to load them as single files and as whole sequences.

If I open the first of the failing Renderama-generated ones in Photoshop and do a "Save as…", it will become recognizable, and will allow me to import the whole sequence of files. So I have solved the situation for now, but… I've tried to see if there is some Permissions difference between the two cases' files, to no avail (I am not that knowledgeable about Unixy issues, anyway). I'd have to do more tests.

I am on OS X 10.5.2 Leopard (Intel), which could be the culprit somehow (this is a job I brought home to try Shader Layering things with a better time margin. In my daily job I operate an OS X 10.4.11-based G5 tower): this silly cat is starting to feel a bit wonky at places, even if I seemed to have avoided the problems that plague others.

That's it, mostly. Has anyone else suffered this thing?

A.C. Farley
04 April 2008, 03:22 AM
I still can't get PHSP multi-layer outta EI at all yet.

04 April 2008, 07:12 AM
Hi Juan,

This is a new problem with AE CS3. The solution as you stated is pretty simple.

1. Move frame one out of the render folder
2. Open it
3. 'Save as...'
4. Save it back to the render folder
5. Import into After Effects, it will now see the first frame and as a result, will import the whole sequence.

I think we need to contact AE support and ask why they can't see our files (but can obviously read them).


Morning Craig,

What exactly isn't working for you, what stage do you get to before it all goes pear shaped??

Maybe I can help :)

04 April 2008, 10:31 AM
OK. I'll check again that it doesn't happen if I do a non-Renderama render (yesterday I tried so by generating a few frames and it seemed to work OK).

04 April 2008, 11:19 AM
Confirmed! Non-Renderama PSD renders work perfectly with AE.

I wonder if this could have something to do with that Unix-based new Renderama implementation: could it be doing something bad when moving PSD frames from the slave cameras to the destination folder metadata-wise or whatever?

A.C. Farley
04 April 2008, 06:13 PM
Thanks! Well, I was all jazzed when I upgraded and tried, following the manual, three or four times but I misunderstand it somehow. I should probably try again after looking at your tutorial, which was my next plan, BTW. I really appreciate your nice offer and if I'm still tripping over myself later, I'll be in touch.

CGTalk Moderation
04 April 2008, 06:13 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.