View Full Version : export skin weight maps not working

05 May 2003, 05:45 AM
Hi all-

I have my character all weight-mapped out on my low poly character. Now it is time to export the weight maps out to apply to the high poly character. So I went to:

Skin>Edit Smooth Skin>Export Skin Weight Maps and into the options menu. I set the export value to "luminance" and the map sizes to 1024 for x and y. Image format to .iff. Then when I hit export, it tells me that 74 weight maps will be created. I hit ok, and then the computer stalls and thinks and creates the maps.

However, when I do all of the this, no maps files are created. The folder that is created which SHOULD hold the maps is empty. Which means that no maps were created.

What is going on! Am I missing a step? :banghead:


05 May 2003, 06:41 AM
I found that the export weight maps are dodgy at best. I tried them a few times with no luck. I would try this approach instead it works great for me. So you got your low poly mapped right?.... Use that to drive the hi rez mesh. You can use a wrap on it, but If the hi rez is just the low rez smoothed then make a direct connection (I think you can use the connection editor to do that). I always use CPS (I bow to CPS), smooth proxy would work the same. With this method you just bind your skeleton to the low rez base mesh and there you go, the low rez now drives the hi rez. This makes it very easy when you're animating to animate with the low rez visible and then turn it off and turn on the hi rez when you want to render. Hope that helps.

06 June 2003, 07:16 PM
Just a note - I realize this is an old post, but someone might find it useful. You have to make sure your object has a UV map. Then it will export.

12 December 2005, 07:52 PM
I know this is an old thread, but I just had the same problem w/ Maya 7.0, then found a solution.

When Maya pretends to save the heightmaps, take a look at the output window for the error log. In my case it was trying to save files with a bunch of colons : in the name. Apparently Maya 7 took the liberty of renaming nodes on my mesh when I imported the file from a previous version.

Change the node names so there are no illegal characters, like colons, then try exporting again. Check the error log to make sure you renamed the right node by again checking the file name it saved. In my case, once the names were good, export worked like a charm.

Hope this helps somebody else.

CGTalk Moderation
12 December 2005, 07:52 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.