View Full Version : nCache

03 March 2008, 07:02 AM
i'v got a heaver meshy file, which i turn into ncloth.
now i'v got a problem in caching. it take too long time .
how to reduce the caching time.

any help.....................

03 March 2008, 07:37 AM

might need some more information from you, it could be a million different things...

How heavy is your mesh? I have the feeling your idea of heavy is different to mine ;)

How slow is your sim?

what are your nucleus settings?

what are your nCloth settings?

Is your mesh clean and even? can you post it?

what is your average edge length in relation to your self collision thickness?

Is the cloth interpenetrating?

I could go on all night, but my sim just finished. So I'll let you reply ;)


04 April 2008, 07:07 AM
to sim just single frame it takes poly count my cloth faces is 10128.

in nucleus

substeps = 70
max collision iterations = 50
collision layer range = 4

space scale = 1.00

in nCloth settings

collision layer= 2
thickness= .078
self collide width scale= .7

friction= .1

stretch resistance=300
compression resistance =200
bend resistance =10
bend angle dropoff =30

damp= 10
collision damp=5

max iterations= 1000
collision flag =face
self collision flag =full durface

actually i'm trying to make raincoat.

04 April 2008, 09:41 AM
>to sim just single frame it takes poly count my cloth faces is 10128.
nCloth should be solving a mesh that light in 30 seconds per frame easy... assuming your geometry is clean.

>substeps = 70
do you need them this high? halving the substeps will most likely halve the simulation time.
I would only have the substeps this high if I had multiple layers of cloth (more than 3) or 1 garment that folds on itself to form 3 layers.

>max collision iterations = 50
similar to above.. try...
substeps 30
max collision Itters 20
it will be over twice as fast, but is it good enough? probably ;)
if you have forces (wind etc) this will totally screw up your existing values...

>space scale = 1.00
WTF! I doubt thats what you want, read the docs on this one.
if you are modelling 1:1 in maya's default cm you will want 0.01...
you have it set up to model 1:1 in meters (i think, duncan will correct me if I'm wrong, so I'll just say it)
As this essentially scales gravity, after you get that right, you will need much lower spring stiffness... which speeds things up...

>in nCloth settings
>thickness= .078
yeah, you dont want a solver scale of 1...
>self collide width scale= .7
be aware, having a self collide width scale < 1 will cause bad self collisions if you paint thickness maps etc...

>stretch resistance=300
>compression resistance =200
>bend resistance =10
>damp= 10
>collision damp=5
these are all too high due to your solver scale, as mentioned above.

>bend angle dropoff =30
doesn't really do anything, go on, make a plane fold on itself and test it.

>max iterations= 1000
>collision flag =face
>self collision flag =full surface

>actually i'm trying to make raincoat.
Oh, why didn't you say so?
just use one of the preset, they actually work (if you have the correct solver scale)
they work because they use the "object space" option under "scaling relation" the absolute best thing about nCloth, ALWAYS use this option, disown friends that dont!

have fun


CGTalk Moderation
04 April 2008, 09:41 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.