View Full Version : Displacement not working in Maya2008 Sp1!

03 March 2008, 09:52 AM
It seems that approximation node doesnt do the job :(

I have opened 8.5 scene with displacement and it didnt work... I have even tried to create it from scratch but withou any succes. I have tried pretty much everything (different tesselation methods) I even changed the type from displace approx to subdiv approx but nothing helped!

heres img for your judgement

Any ideas boyz?

Thx a lot for any input!!

03 March 2008, 10:52 AM
Here works as expected with Extension2 (sp1).

03 March 2008, 01:03 PM
I've just tried it. For me it works ok with a displacement-approximation (but not if I also use a subdivision approximation).

But then, by accident, I noticed that it works much better and much, much faster with no approximations at all.:eek:

I've simply connected a solid fractal to the SG's maya displacement material slot and it renders really fast. Then instead I tried JS_Wood (with black and white colors) connected to the SG's mentalray displacement shader slot and it also renders really fast.

With nurbs, "feature displacement" must be on, but for polys it works either way.

I noticed that if my displacement texture is set up so its just black, then the surface renders as if it has a subdivision approximation attached (ie nice and smooth - but only if the edges are "soft") so something must be going on internally...

I dont remember it being like this before, but I dont often use displacement because it always seemed too slow.

Maybe someone can shed some light on this. Its probably mentioned in the manual somewhere - I havent had time to look yet.

-- David

03 March 2008, 01:06 PM
Here works as expected with Extension2 (sp1).

03 March 2008, 01:43 PM
try this "Windows > Settings/Preferences > Rendering > Mental Ray Preferences" check "Use Maya-style alpha detection on file textures"

03 March 2008, 01:53 PM
thx guys! I really appreciate your input!

Well I have already tried to check the "alpha thingy" in the Preferences but theres no any change...

djx > I have also noticed this but I dont really understand it because in older maya version one had to switch "Feature Displacement" off in the shape node of the geometry when using MentalRayApprox node. But in M2008 it does not have any influence when on or off!

It also seems that the problems comes when using bitmap files not procedurals which works no matter if mrayapprox node is attached or not!

Really really strange to me I dont get its possible Autodesk did not test it perfectly cos its in updated features in 2008 SP1!!!

There must be something else...

Anyone have similar problems?!

Thanks again for your interest and help!


03 March 2008, 07:21 PM
Well I finally got it! For some strange reason the "Lenght" parameter in "Spatial" mode has been reset to zero value which obviously caused the problem! I accidentally change it from 0 to anything else and it started to work!

I swear that in Maya 8.5 it was working from the begining default value and for some reason it changed...

well here is the screen for everyone>

03 March 2008, 09:22 AM
Libor could you please post your scene for me to look at.


CGTalk Moderation
03 March 2008, 09:22 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.