View Full Version : Mental Ray + particles + batch render = not working

05 May 2003, 02:26 PM
Just being doing a project using particles systems lots of ray tracinig etc and i tried rendering it in Maya 5.0 with mental ray and for single shots everything is fine you can see the particles.

BUT when you batch render the same squence you get no particles. The only difference is that i select batch render instead of render view.

I tried this on 2 freshly built machine exact same problem..

Anyone else having this problem ?

05 May 2003, 04:54 AM
Did you make a particle cache first?

05 May 2003, 08:37 AM
Yerp i tried that seems like a bug to me.

Can anyone else reproduce the problem ?

06 June 2003, 04:53 PM
the same thing happens to me, in single frame render that's ok, but when I try the command line batch render (mayarender_with_mr), the particles just don't render.

I have tried with and without a particle disk cache :shrug:

It looks like a bug for me too.

06 June 2003, 08:55 PM
same thing here, but i tried with a very light scene (just a testscene) and it worked. In the doc they say that u can not have a lot of particles when using mentalray, so this might not be a bug but a limitation. This one has to be fixed anyway!!!


06 June 2003, 01:39 AM
I spoke to alias support its a "known limitation".

But there is a work around, if you render single frame in maya using mental ray it works no matter what frame you are at.

I got a mel script from alias that renders a frame with mr saves the file then goes to the next, i had to rewrite some of it but it work okish now.

I rendered 500 frames with this method no problems.

I'll post the script when i get home

06 June 2003, 03:19 AM
Cool, I was trying to write a script to do this, but I didn't find much documentation about MEL commands to render with mental ray. It seems, that a command "Mayatomr" is used to do that, but I can't find more information about it.

Anyway, I'll be very grateful if you share that script with us :thumbsup:

Thanks !!!

06 June 2003, 10:36 AM
Ok guys here is the script i hope it helps some of you.

Where it says;


The "c:/abc/images" is the path where the files will go, change this to suit

The "Babak" is the filename change this to suit also.

Make sure you get MR selected as the renderer.

The rest of the instructions are in the header of the file enjoy :buttrock:

08 August 2003, 07:57 PM
Since I have been running into problems with batch rendering using MentalRay as well, I need to use this script.

...but, I need my images in the .tif format, not .iff

Is there any way to save the image files as .tif instead of .iff? Please say there is a way!

<EDIT> I just tried out the script, but after it renders each frame, it gives me an error: "Failed to open IFF file for writing : Users/conferenceroom/Documents/maya/projects/testMEL/mentalRay/images/ball20.iff"

If I go to that folder, the files are there, but when opened in Fcheck it says they cannot be recognized by the program.

08 August 2003, 01:55 AM
I'm at uni now i will check it when i get home.

But what you can try doing is rendering anything then go file save and choose the format you want.

Have a look at the setting in the script editor and use thoes setting in the script.

12 December 2003, 09:52 AM
I had problems whit particles+mr+batch render.

I render my animation to jpg images and no problems.

01 January 2004, 07:21 PM
I downloaded the script and looked at it but how is this different than batch rendering in Maya??

01 January 2004, 07:00 AM
It not that different but what you will find is when you try to do a batch render or command line render MR in version 5.0 will not render you particles correctly.

If render any particular with MR but just using the render window it will work fine with the particles.

So all the script does is renders a frame in the render window saves the file then goes to the next frame and renders it etc etc etc.....

01 January 2004, 10:17 PM
Thank you for your reply. I'm not sure if this is I'm looking for, but I'll give it a try and see.

I also had a problem with cache when I MR render from command line that the job cannot find the cache file...
Did anybody have this problem before? Any suggestion to get around it??

Since it cannot find the cache, when I try to re-render a few frames from the sequence, positions of particles are different...

01 January 2004, 12:16 AM
Are you sure your render is pointing to the correct project folder ??

03 March 2004, 04:49 PM
the script worked
Ithought I lost it

03 March 2004, 11:20 AM

thanks so much for posting this info

works beautifully

God and Jesus sent this through you

thanks again


03 March 2004, 01:47 PM
Hahah i am glad people are using it and its helping them been so long since i posted it and yet it still seems to pop up :)

CGTalk Moderation
01 January 2006, 02:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.