View Full Version : Weird Maya Behavior

02 February 2008, 12:48 PM
I have a simple script below:

global proc int TestProc()
print("This is TestProc\n");
return 0;

I used to put it in maya scripts directory (the one My Documents\maya\7.0\scripts) and it worked fine and Maya sourced it automatically at startup and then i could use TestProc everywhere without having to source it explicitly.
The problem occured when i had to install Maya5.0 to fix some issues. Ever since i installed Maya5.0, both my Maya versions have stopped automatic script sourcing. I have looked at all sorts of environment variables and they are all fine. I have even tried setting them up explicitly (through the .env file), but nothing works!
I have even tried placing this simple script at all the locations in the MAYA_SCRIPT_PATH environment variable but to no avail.
It seems that Maya just wouldn't source any scripts! Shelf scripts are loading up fine, though. All i want is for Maya to source this script at startup and its just not doing that. I am totally stuck!
Thanks for any help.

02 February 2008, 10:51 PM
to be safe I only put my scripts in the my documents/maya/scripts folder and ignore the version specific ones.


CGTalk Moderation
02 February 2008, 10:51 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.