View Full Version : No visual feedback on painting skin weights

01 January 2008, 02:50 AM
As with some other users, I can't seem to get visual feedback painting skinweights... This is a big problem.

I'm using 8.5SP1 for win32, and a quadro fx550

01 January 2008, 05:07 AM
are you using some deformers above skin cluster..
sometimes when i use psd or clusters(specically when matrix informatio is changed over cluster node) i get same problem...

i solve it by rearranging order of deformers

01 January 2008, 11:47 AM

i have exactly the same problem? did you installed the extension1 (muscle plugin) of maya?
i have no clue what i can do to fix this prob.

01 January 2008, 05:52 PM
try reordering input orders.. make sure to read script editor when you do that,,

or save skin weights using some script..(comet save weights)

and delete it and recreate skinCluster..

i dont know the exact cause...why it happens

01 January 2008, 07:17 PM
Maya 8 and 8.5 have a LOT of animation and rigging-related bugs. Our Animation TD prefers working in 7.0 when it comes to rigging... I guess I'll try and do that until the bigs have been worked out. We haven't deployed 2008 here at the studio, yet, so I can't comment on whether this bug is fixed.

It happens with a fresh install of 8.5. I also installed bonus tools. No idea if that should have an impact. All I have is a straightforward smooth bind. Still no resolution. I'm going to try some of the workarounds suggested here.

01 January 2008, 08:56 PM
anyone makes any steps forward because of this problem?
i exported my mesh as an obj file, imported back and i was able to use paint skin on my maya at work. at home the same workaround doesn't work.

01 January 2008, 06:09 PM
double post, sorry

01 January 2008, 06:10 PM
I think its a bugginess in display/updating... When I changed drivers on my quadro 550, it made no difference. However, i found that if I toggle between color view and grayscale in the weights (there's a pulldown item on the paint weights tool), and go back to grayscale, the weights I just painted miraculously show up...

It must be some OpenGL optimization problem, which I can't do anything about (cough Autodesk!). In the meantime, it is really tedious to keep going back and forth like this, thank god I don't do character setup all the time.

Others with this problem should try toggling back and forth between color and grayscale view, to see if you can reproduce this phenomenon.

CGTalk Moderation
01 January 2008, 06:10 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.