View Full Version : imported character problem


endsjustifyme
01 January 2008, 09:09 AM
I am having a problem with a character that I rigged following a tutorial. The controls and the rig seem to work fine but after importing it into a different scene, and setting it up in a pose and animating some of the controls, I save it, and when I reopen the animated file, the character is in a different pose, some of the controls go back to the bind state as if I had never moved them, while some of them are in the positions where they were when I saved them. I am confused as to why this is happening and I am hoping that someone here can tell me what to look for to fix my problem. I am just starting to learn maya and I am not good at rigging. I used the digital tutors quadraped rigging to help me set up my character (a dog) skeleton, rig, and controls. If anyone has any insight into my problem, or better yet, a solution, please either respond to my post here, or even feel free to email me at xjenx@trustkill.net Thank you for your time in reading my post.

shinyprem
01 January 2008, 02:48 PM
Hi..!
Yes this happens rarely.. no idea till now why it happens. Solution: save the animation and the scene file. In case of similar sitiuation laod the animation thro some mel like dkAnim.

Rgds,

Buexe
01 January 2008, 02:51 PM
Are u using references? Could be a source of this "feature". Try scrubbing the timeline after opening the scene. If this doesn`t help, try setting keys on ALL RELEVANT ATTRIBUTES ON YOUR CHARACTER. THis way you force Maya to use the Attribute values in your scene file.

Hope this helps

knoxie
01 January 2008, 10:40 PM
try keying EVERY control that you move, not just the ones that animate. Anything that is not keyed may move back to 0,0,0 in translate rotate and scale.

johnchuang
01 January 2008, 12:59 AM
especially, key the global control at the start frame.It might work.

Buexe
01 January 2008, 01:23 AM
KEY, KEY, KEY! and then KEY MORE! :)

CGTalk Moderation
01 January 2008, 01:23 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1