XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : painting weights - no color feedback?

01-08-2008, 08:13 PM
I am forced to create a new thread for this because the search function is returning an error and I need to some this problem asap.

I have a new character and rig which I have smooth bound and need to paint weights. However, when I access the paint skin weights tool, the mesh stays gray and I get no color feedback. I have ensured that the necessary check boxes are on (i.e. color feedback or multi-color feedback). I have also turned off wireframe. I ensured that the mesh was in fact bound as it does react to the rig.

I have tried resetting all preferences to default. I even deleted all of my prefs and restarted maya so it would create all new prefs for me.

Additionally, as a test, I created a cylinder with a few joints and I get the same problem. I also tried the soft mod tool and I get no color feedback there either.

I also tried downloading an "update" script from a site I found through Google ( http://www.ericpierce.com/tools.php (http://www.ericpierce.com/tools.php)) It has the same features as the original tool, but also has the option to lock weights and toggle color feedback. This did not work either.

I have also reverted to a backup norton ghost file which restored my computer to the point of a fresh maya install. Still no luck. The really wierd part is when I tried this on my old computer. I still didn't get any color feedback.

Running Maya 8.0
Nvidia Quadro FX 1400 on one machine and Ati x800 on the other.

I have not tried updating drivers because the problem is occuring on both machines with different hardware.

Please help. Thanks.

01-09-2008, 08:27 AM
I have experienced the same problem many times now but unfortanately I haven`t found any solve to that . If anyone have a suggestion I would like to know it too.

01-09-2008, 03:39 PM
After several hours trying absolutely everything I found a solution. It seems that its just another small bug in maya. I tried opening an old character that was already rigged. Once I did this, and opened the paint weights tool, color feedback worked just fine. However, if I went back to the new character, it didnt work. So, back in the old scene, I deleted everything and imported the new char and rig. For some odd reason, this worked.

01-23-2008, 02:59 AM
I am having the same problem using maya 8.5...

the paint skin weights tool does not update. Using the Flood function does update, but I have to be able to see what the paint tool does...

02-11-2008, 03:15 PM
Have you tried deleteHistory... this many times solves many display issues in maya... or you can even... try polyToSubD and back... that should solve the problem...

02-12-2008, 12:31 PM

I'm not sure if this will solve you problem but I had the same problem and after much searching it turned out that 'use default material' was checked on under 'shading' in my persp window. once this was unchecked everything displayed as usual.
I don't know if this is a new thing in Maya, I've never notced it in all the years I've been rigging! anyhoooooo.... maybe that helped.


02-12-2008, 02:00 PM
Am I doing something wrong here? my replys to threads don't seem to show up!!:sad:

02-12-2008, 02:04 PM
I had this problem, It was driving me Mad!
It turned out to be the simple fact that I had the scene in 'Use Default Materials' mode under the pesp window 'shading' drop-down menu.
I'm not sure if this is new to Maya but I've never come across it in all the years I've been setting up characters... very odd.
Hope it helps



01-23-2009, 08:24 PM
YES! 'Use Default Materials' was the culprit in my scene as well.

CGTalk Moderation
01-23-2009, 08:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.