View Full Version : Solution for the playblast bug in XP?

04 April 2003, 02:31 PM
Anyone know of a fix for the playblast malfunction in XP? It's driving me NUTS:scream: :D :annoyed:

04 April 2003, 04:09 PM
stop any "pop-up" process (like msn) and don't click anymore until the end of the playblast.
Note this problem doesn't happend on UNIX workstation.
P.S.: I'm also waiting for a better answer;)

04 April 2003, 04:18 PM
Well, that won't work either.

I've noticed you have to have the scene played through, just saved, no windows open (such as attribute editor or hyper graph), and sometimes it still won't work... Gaahhh!:D

Note this problem doesn't happend on UNIX workstation

No, seems to be XP related...

04 April 2003, 06:39 PM
yea, its a known XP bug with maya:
Under some circumstances, when playblasting an animation, partway through, the playblasting ceases to be updated. Attempting to ESC from the playblast may cause a hang.

Solution: None.

my solution: dont use XP :)

04 April 2003, 08:47 PM
my solution: dont use XP:)
A bit late for that... Arrgh

Anyway, does anyone know if this problem still exists in Maya 5?

I noticed this can happen when you do a particle disc cache also. As far as I could tell the cache still worked, but you never know...

04 April 2003, 08:37 AM
I think this problem's also hardware-related. Happens all the time on a FireGL 2, but never (touch wood) on a Geforce4!? Anyways, another temporary solution would be to use the hardware render buffer, then you can get yummy antialiasing as well.:)

04 April 2003, 09:45 AM
Hm, running on a GeForce4 Ti4800...

Yes Hardware render buffer is of course a great suggestion. But I am currently animating fur attributes and need to get a fast feedback on how it moves and the obvious would be to just hit playblast and see how things move. This would be a fast solution if it only worked. Now it works abut every 5th try.

Well, thanx guys, doesn't seem to be any fix out yet. Let's hope for Maya5 or maybe next Windows version...

04 April 2003, 09:31 AM
yeah they didn't call it Xtra Problems for nothing...

04 April 2003, 05:41 PM
So here is the scoop as i have come to understand it.

Firstly the issue is not limited to XP, but to Maya 4 through 5 on everything but Irix 6.5.11 and on.

I believe the issue is caused by a temp file failure that halts the process about 20-35 fames into the write.

Certainly any other process which occurs is bad, so the first thing to do is open windows media player or fcheck (i use media player) so that is does not call it during the write process. If it happens you will have to restart Maya since there is no way to flush the cache, which is what appears to need to happen. I think that is why the issue never appears until around the third or fourth playblast. Hardware, length, compression or size do not appear to cause the error, only a kind of buffer over-run.

Irix does this flush automatically and that is why i believe it does not have the issue.

Maya could really use a 'Purge Cache' function like Photoshop, especially since it leans so heavily on the x:\DOCUME~1\usr\LOCALS~1\Temp file.

For right now, the only work around which seems consistently to work is the whole restart Maya option.

04 April 2003, 09:43 PM
Interesting. I also noticed this happens when building a jiggle cash.

The thing is I can't see the pattern. I can do 10 playblasts in a row without success and suddenly it works... One time...

05 May 2004, 12:13 AM
This is really annoying. I thought I'd revive this thread again since Maya 6 has come out to ask if anyone still experiences the problem.

I'm playblasting fluids (ponds and wakes) and it's really annoying to have to try and playblast 10 times to get one that finally works!

05 May 2004, 12:28 PM
Since it was I who started this thread more than a year ago I might also be the one to shed some light on the problem.

For me the problem actually spells g-e-F-o-r-c-e.

I tried everything and people recommended me to change compatibility mode and stuff, but nothing worked. Then we got new workstations with Quad-cards and it still didn't work, but when I changed compatibility mode this time it suddenly played like a blast.

I have a two 21" monitor system now with a quadro4 980XGL card and I can even surf CGtalk while playblasting! But I need to use the driver specified by Alias. 43.51 I think.
And as an extra bonus my time line marker in the Graph Editor is RED!

edit: clearifying edits

05 May 2004, 01:27 PM
ah ah.. not only geforce..
same problem with the ati 9800 pro..

after switching to cmpatibility mode with win2k it was gone as well..



06 June 2004, 02:44 PM
Could it be a problem of the cursor?
I mean: if I don't touch the mouse until the end of the playblast it works fine!

06 June 2004, 08:13 AM
Well, I would rather say that this happens when windows looses focus on the viewport you are using for your playblast. This mainly occurs when there are other Maya windows open such as hyper graph, blendshape editor and such. Maya usually shuts down these temporarily to aid playblasting, but it seems that this isn't enough on some cards. And on these cards you can't under any circumstances change focus to another window while playblasting. I never experienced any problems with moving the mouse under a playblast session, but on the other hand I didn't dare touching it. I even held my breath...
But if you really need playblast to work smoothly, buy a Quadro card and change compability mode for Maya to Win2K, and it will solve all your problems.

06 June 2004, 11:32 PM
This error occurs on Quadro FX 3000's, so the cards I don't think have anything to do with it.

06 June 2004, 09:12 AM
SOLUTION: right click on Maya shortcut icon, go to compatibility tab and choose win2K, thats all.
It's an XP "feature" not a Maya bug. Also u may want to set this for other aplications too. It will spare a couple of years for longer life :)

06 June 2004, 07:23 AM
compatibility mode makes it only a bit better here.. but it does not fix it completely :/



06 June 2004, 08:04 AM
This error occurs on Quadro FX 3000's, so the cards I don't think have anything to do with it.
Well, nevertheless... It didn't help changing compatibility mode on our geForce's, but it worked just fine on our Quadro4 980GXL's. On all our workstations I might ad.

07 July 2004, 08:12 AM
UPDATE: Maya 6 still has this problem. I'm running Maya 6 on Windows XP, with an ATI 9800 Pro video card. Switching the system to Windows 2000 Compatibility mode appears to have solved the problem (APPEARS). I'll post again if it fails in the future.

07 July 2004, 09:41 AM
I'm using a geforce card on xp as well and never had an issue with PB. This is just a wild guess but have you guys tried forcing the v-sync on in the vid-card settings? You could try to switch off the write caching too for the HD which has your temp folder on... Again... just guessing here...

07 July 2004, 09:22 PM
I have a problem that may be related: the playblast file plays very slow in media player. This didn't happen with the last scene I playblasted... Looking at the file's properties (under summary), I can see that the "frame per second" attribute is 1 !!!! not 24.
What is going on? I haven't changed anything in the settings since I worked on the last working scene...

07 July 2004, 07:54 PM
hey I am useing zzPlayblast.mel and I don't have problems like I have with maya playblast, it work cool on XP.
You can find this script on Highend ofcourse:)

hope this will help

11 November 2004, 04:40 PM
Great tip about the compatability mode- works even better in NT mode- this bug seems to affect any busy software which looses context and does not have a refresh thread to update the screen. Rendering has always been a pain for me as doing something else whilst rendering will always cause maya to freeze and take twice as long to finish, and not update the display. I suppose the XP bug makes up for the random crash bug when batch rendering UV linked objects in Linux!

11 November 2004, 12:55 AM
I may be heading in the wronge direction here but the other day my friend was having trouble with his playblast just freezing at a certain frame everytime. He was told to create a new camera and once he did and was playblasting through the new one everything was working again. Full playblast.

12 December 2004, 12:28 AM
weird....if you change the windows "theme" to classic that fixes the problem as well..this is the weirdest bug I've ever seen. Anyway, works fine now with tha classic style.


12 December 2004, 08:59 AM
yea I have notice too that with classic style playblast woirk better:)

03 March 2005, 08:53 PM
i have an xp amd 64 bit, abit kv8 max 3, 1 gig of RAM, ati radeaon 9800 pro 128 MB. I have maya 4.5 and 6 installed....XP is set to all classic....compatibility to windows 2000, and even disable visual themes etc......DOESNT WORK!!! What really ticks me off is that it did work at one time? ( i had to rebuild the system - but everything is exact)
This playblast problem is a real pain...SOMEONE HELP

03 March 2005, 12:44 PM
This threat has been reinvoked the 3rd time now, huh?

I use an ATI Mobility and I ran into this bug again after switching to XP. I am so looking forward to get a can of coffee and try all the suggestions listed here.. hopefully IŽll
FINALLY get rid of thisi pain in the bambam

One thing though that I figured out - once my beloved Maya 6.5 has decided to no longer playblast, the playblast ALWAYS freezes at the same frame (provided I donŽt change anything). Now, it will freeze LATER if I change the output size of the playblast. This seems to be quite proportionally!!! Freeze at frame 10 when size = 1.0 -> Freeze at 20 when size 0.5.
Not tested thoroughly though.

Dr. Ira Kane
03 March 2005, 01:17 PM
That's weird guys I have never had any problems with playblast, I have win xp sp2 (with all that visual crap turned off ) and maya 6-6.5 set to w2k mode ( it's more stable that way) and I didn't notice any freezing in playblast or other problems, and no I don't have qualified hardware :D

03 March 2005, 03:22 PM
maya 6-6.5 set to w2k mode

might sound dumb, but how do you do that is it something on windows or maya..?

thanks for the answer


Dr. Ira Kane
03 March 2005, 03:46 PM
Well the 6-6.5 means that this applies for version 6.0, 6.01 and 6.5 I don't remember how it was in earlier version, the w2k mode (windows 2000) is a feature you can enable in .exe if it causes some errors, just click on maya .exe and then set the compatibility mode to windows 2000, that way I gained much more stable app, no crashes etc however it still has some serious memory leaks :(

03 March 2005, 03:53 PM
might sound dumb, but how do you do that is it something on windows or maya..?

thanks for the answer

It has probably been posted quite a few times, but what the heck:

Right click on your maya desktop icon (or whatever shortcut you are using), go to properties, go to 'Compatibility' tab, check 'Run this program in compatibility mode for', select 'Windows 2000'.
Now maya runs in compatiblity mode for w2k.

Little sidenote: I personally have problems with that because everytime I press the F1 help button my IExplorer rearranges my customized buttons/bars.

Dr. Ira Kane
03 March 2005, 03:56 PM
It may be shocking but I have never hit the F1 help button :D ( it doesn't mean that I didn't use help....)

03 March 2005, 04:02 PM
It may be shocking but I have never hit the F1 help button :D ( it doesn't mean that I didn't use help....)
Ehehe, yeah I guess it's one of my bad habbits I cant break... Seriously! :D
And since I dont have problems with the blanking bug it's ok how it is. :)

CGTalk Moderation
03 March 2005, 04:02 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.