View Full Version : symbolButton - passing arguments

12 December 2007, 05:15 PM
I'm making an UI element and i'm having trouble passing an argument to a procedure from symbolButton's command;

symbolButton -c "my_procedure($someID[$i], $someName[$i])";

I've tried all types of quotation mark and bracket variations, even tried putting variables in single string and passing them, but they just won't get in to that procedure. I can't google up any similar example that would help me with this problem, so I was hoping any of you guys ever did something similar and could help me out here?
Any help is much appreciated!


12 December 2007, 10:39 PM
Hi, I hope this works:
symbolButton -c ("my_procedure "+$someID[$i]+" "+$someName[$i]);

Basically you are right to pass arguments like:
command(argument1, argument2);
However, this works too and is a little bit easier IMO:
command argument1 argument2;

12 December 2007, 08:55 AM
Buexe, this worked.
Thanks a lot!

CGTalk Moderation
12 December 2007, 08:55 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.