View Full Version : jsReferenceRig Script probs

04 April 2003, 07:27 AM
Hey everyone

If you don't have the Fast Animation Rig DVD from AW then ignore this one.

One of the scripts is jsReferenceRig and I can't get it to work. When it's setup, an error message comes back when trying to copy the animation from the high rez to the low rez rigs saying

"there was nothing to of your rigs isn't setup properly"

but i have no idea what is wrong.

Any suggestions?

04 April 2003, 12:06 PM
Check out this thread for a fix to the script(s):

(thanks again Daniel!)


04 April 2003, 01:28 PM
tried that, and i get the following error when i try to locate the .rg file with jsReferenceRigUI

"// Error: Cannot find procedure "jsPerformRigReference". //"

Anyway i could send you my edited scripts so u could look at them? or you send me your edited ones?

As u can tell, i know jack about mel scripting :)

04 April 2003, 01:40 PM
i just retried it and a

"syntax error" comes up...

and then

// Error: Cannot find procedure "jsErrorMsg". //


04 April 2003, 02:01 PM
Copy ALL the scripts off the DVD into your scripts directory (but don't overwrite the 2 fixed ones!) restart Maya, and give it another try :rolleyes:


04 April 2003, 02:09 PM
still no good

I get "syntax error"


04 April 2003, 02:30 PM
Hmm. It's probably the edit to the scripts you did then. Give it a closer look - I'm not at my computer and have another 12 hours till I get home, but if you still need help then...


04 April 2003, 02:36 PM
Thanks Jay

Tried to go through the script, but i just can't make much sense of it.

Just mail me when u can take a look at it.


04 April 2003, 02:48 PM
ok scrapt that last request Jay, solved the previous problem.

hehehe...but alas, solve one problem and another pops up!

now when i try to copy animation, and error comes up saying

Error: Cannot convert data of type float[] to type float.

...but haven's had time to try n solve this one, need sleeeeeep

04 April 2003, 03:17 PM

I got it to work!!

Thanks Jay...and Mr. Schleifer!

04 April 2003, 04:54 PM
Sweet workflow too, huh? Thanks Jason, and Daniel for the fix.


04 April 2003, 11:51 PM
Yeah very nice indeed.

Are you limited to having one reference in a scene at a time. Haven't tested it, but just curious.

04 April 2003, 12:33 AM
Have another small problem...

The script works a totally brand new scene file. However, when i try n use it an existing scene i have built (sets n buildings) it won't work.

More specifically, the jsReferenceRigUI scripts work fine, and i can reference in both the rigs, however, as soon as i type in jsRigUI and error message comes up saying

"Error: Cannot find the scene file."

any suggetsions? Obviously this error must be scene specific, because the scripts work fine in a new scene.

04 April 2003, 12:41 AM
I've always used it in a new scene too. But try this: use your existing scene, set up the referencing, save out the scene, then close it and re-open it. Maybe...?

(haven't tried multiple refences yet either...)


04 April 2003, 01:04 AM
nah...still the same problem....


04 April 2003, 01:40 AM
Be nice if Jason stopped by...:)


04 April 2003, 05:51 AM

I tried everyting, importing the scene file into a new file and then running the script...i tried saving the file and reopening, i tried different rigs etc...but i still get the same error!!!

// Error: Cannot find the scene file. //"

Help us're our only hope!!!!

04 April 2003, 08:54 PM
woah.. weird!

sorry, just saw this thread.. I'll try and spend some time this weekend on the problem (been a crazy week at work & I just haven't had any energy by the time I get home to do anything but eat my dinner, plop in front of the tv, and clean up dog poop :)

it might be spelled out earlier in the thread, but if you could specify step by step how it's busted I'll do my durndest to fix it.


04 April 2003, 06:40 AM
ok, thanks Jason

Step by step...

1. Open scene file (not new, contains buildings, camera's etc)

2. Run jsReferenceRigUI with the fix posted on the other thread. Works fine

3. Run jsRigUI and i get the following error

// Error: Cannot find the scene file. //"

Now, the strange thing is, that when i export everything into another scene, it actually works, and i don't get an error.

And what's even stranger is that it works fine on a brand new scene.

Weird huh!??!? If u can't find the prob, i'd be happy to send u the scene's that don't work.

04 April 2003, 01:51 AM
okay, so I've done a number of tests, and I just can't seem to get it not to work!

i'm running on Mac, so it may be an OS thing.. can you please send me the files so I can test with something that we know doesn't work?

Here's my email:


04 April 2003, 04:42 AM
ok...just send the email with all the files, let me know if it doesn't get through.

Thanks Jason

04 April 2003, 05:11 AM

I'll try and check 'em out tonight!

yeehaw! :)

05 May 2003, 05:35 AM
Did u ave any ideas about the js_Copy_anim error Jason?

PS. Went to the AEAF (Australain Animaiton and Effects Festival) on the weekend, and Bay Raitt spoke to us about LOTR. Excellent Work on the Gollum rig might I add, was truly amazing, I almost fainted when he showed us tha actual gollum rig in Maya!!!

Just curious, did u build the interface for the facial setup...i especially liked the little left/right side of the face icons :)

Actually, while im on the topic, Bay spoke to us about how Gollum could have more than one facial blends applied to his face, and that you guys solved the problem of being able to blend two facial expressions without it "breaking". I was a little confused as to how you guys solved this problem, as Bay said you simply created another blend for the imbetween areas? Not too how this worked. Could you maybe elaborate a little?

Thanks Jason (and Bay for the wickid seminar at AEAF!!!)

05 May 2003, 08:06 PM
oop, haven't had a chance.. been overseas! :)

Thanks for the kudos on the gollum rig.. 'twas quite fun to put together.

Bay & I built the interface together.. the icons are his, tho. :)

What bay was talking about is something called "combination sculpting" where he will sculpt a "fixit" shape for two or more shapes which cause the face to break. To simplify it a bit, imagine this:

You have a point which is at 0 0 0. You add a slider "Happy" which moves it to 0 10 0. Another slider called "george" moves the point to 10 0 0. When you put both happy and george to 1, the point moves to 10 10 0. However, you actually want the point to be at 10 5 0, so you make a "corrective" shape which is at 0 -5 0, and you make sure that when you set "george" and "happy" to 1, that corrective shape is also at 1.

Does that make sense?


05 May 2003, 12:11 AM
ahhh...very interesting. Was the technique perfect, or were there occasional breaks? I guess if it did break, you just made another 'fix' blendshape to compensate?

However, what happened when u wanted to blend more than two shapes? And i know that gollum had around 64 base facial shapes and over 900 overall facial blends, but that still wouldn't compensate for every different combination of blends?!?

05 May 2003, 03:17 AM
we had it working so you could make an unlimited number of combinations.. it got pretty unweildy, but you just had to end up making some decisions about things and allow for holes in the network where you could get away with them.

there were occasional breaks, but the amount of control it offered was beyond anything I have ever seen before.


12 December 2005, 10:23 AM
Not sure if this thread is still going but I'm having some issues with the jsReferenceRig scripts in Maya 7.0. Seeing as how its a really old script I'm not sure if its supported anymore.

Anyhow Jason if you're still reading this thread and willing to be bugged about this set of older scripts then post a reply and i'll elaborate on the issues I'm having :)



12 December 2005, 03:49 PM
heya dave!

I haven't looked at the script in a long time, but I'll try and answer your q's.. what's the prob?


12 December 2005, 01:05 AM

Thanks for the prompt reply.

Ok a couple of problems is that we cant seem to use the referencing scripts to reference in more than one character at a time. (even the macguy scene)

The second problem is that one of our characters will reference into the scene fine but as soon as you try to view the reference UI it says "Error: can't fnd the scene file"

If you go and turn off both the Lo and Hi reference files in maya's reference editor then the reference UI script will load up the correct data and you can switch between the rigs fine. But then the next time you load up the reference UI script it has the same problem.

I think both problems have to do with the reference file renaming stuff.

To cloud matters further I think we are operating on the old 4.5 scripts (dated October 2002). How do you get the newer updates (if those scripts were updated in the new DVD rollout that is)



PS. If you want a scene file to look at I can either send it to you or put it on an ftp area somewhere for you and send you the log in details.

CGTalk Moderation
12 December 2005, 01:06 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.