View Full Version : How to animate wind strength?

10 October 2007, 05:34 AM

I have a very small particle system setup. Using PF Source and a Force operator that has a wind space warp attached to it.

I have a 200 frame animation, where I'd like the wind strength to decrease from its initial strength (1) down to zero in, say, 50 frames. This way, the animation will start out as the wind blowing particles upwards for 50 frames, and by that time the wind dies out, so the particles will fall back down.

The prollem is that for whatever reason I can't animate the wind's strenght parameter. It has 2 keyframes (frame 0: strength 1 and frame 50: strength 0). I can see the value decreasing down to 0 during realtime playback, however, the actual particles in the viewport are still being blown by the wind.

The particles have no "speed" operator. Instead I have another force operator that has gravity attached. So the particles are being blown upward for 50 frames, then gravity pulls them down (after the wind dies out - but it doesn't).

So the question is, why does the wind strength value (in the parameter panel) goes down just fine during animation, but its actual strength don't seem dying down when watching the particles' movement in the viewport?


10 October 2007, 06:34 AM
I believe I understand what your problem is. That is the way Max Wind works. Think of it in an enviroment like outer space, where there is no wind resistance or other forces applied. Once the Wind gives a particle the energy, it keeps it without loosing it unless an alternate force changes it. A solution is to use Drag.

10 October 2007, 01:03 PM
Another thing you can do is put in an age test in your pflow. This way after 50 or so frames the particles will stop being effected by the wind. I think the drag will work great also, it is really going to depend on the type of effect you are looking to achieve.

10 October 2007, 03:01 PM
An Age Test will give the same result as animating the Wind Strength to 0 (if it is set to Absolute Age), otherwise it will have no effect on slowing the particles. You need to introduce another opposing force, or introduce a new speed amount to make the particles change speed.

10 October 2007, 04:58 PM
Yes, I must've done something wrong because I've tried age test. After 50 frames, the particles enter a new event, where gravity pulls them down. But actually, they don't. As if the age test has no effect on them at all.

I will have to see what else I can do when I get home...

10 October 2007, 01:29 AM
animate the influence of the force...if u want it to be continuous use out of range types.

10 October 2007, 02:07 AM
Thanks for the input guys. I'm slowly getting a hang of it. New to particleflow...

10 October 2007, 02:44 AM
Is this what you are trying to do?

Edit:-attached R8 file with Gavity and aniamted Wind Speed

10 October 2007, 05:26 AM
Thanks, but unfortunately I can't open it. I have max 8. :-(

10 October 2007, 12:38 AM
I updated the file to an R8 version. Use the attachment in the above post.

10 October 2007, 06:19 AM
Ok, first of all, thanks very much for the file. Yes, that's pretty much what I wanted.

Second, I'm beginning to think that there's something got corrupted. When I play your file, yes, it works. However, that is exactly what I've done before, animating the wind strength and it doesn't work for me.

Even if I reset max, and try to recreate your scene, it doesn't work. The animation is being played back in a loop constantly. In one run/loop, the particles are either completely ignore the animated wind strength, next run, some particles might just decide to shoot off in whichever direction, the third run they play back completely jerky and at frame 30 or so they just completely disappear from the viewport. And so on and so forth.

As I recall, a few days back our power went off while I was rendering out a sequence. I'm not sure if something got corrupted at that point or not, but seeing that your file plays back just fine, I'm beginning to think that.

Maybe I will have to try a reinstall...

-Max 8 SP3
-using latest nVidia 7900GT drivers. tried to revert it to the older version but same result
-DirectX 9c

10 October 2007, 10:24 AM
Well, at this point I'm a little puzzled, and frustrated. I've reinstalled max - thinking that it might solve the prollem, but it didin't.

The particles are randomly jumping all over, sometimes they are completely disappear from the viewport even while they are spawning. So I'm unable to recreate that file even if I have the exact same parameter values.

Completely clueless... :sad:

10 October 2007, 11:15 AM
Could you post your .max file so we can take a look and see if it behaves, just like you say, on our own machines?

10 October 2007, 11:34 AM
Sure. Here we go.

A little update since (just in case). After I reinstalled, nothing has changed. So I started to keep changing drivers to OpenGL to Software to DirectX 8.1. Then back to DX 9. At this point something happened, because now I am able to construct the animation. However, in the PF event, for the Force operator I have to set the "Offset Influcence > Sync By" parameter to something other than "Absolute". If I leave it on "Absolute" weird things happen. Anything else is close to perfect.

However, the file posted by charleyc can be set to "Absolute" and still plays perfectly.

10 October 2007, 12:11 PM
Well, the problem it's not your 3ds Max (config) :)

I tried to make an similar simulation in your maxfile and encountered similar problems. First I thought it had something to do with animating values when you have them (wind, gravity) already in your flow, but that doesn't seem to matter.
Then I took a look at Charleys file and compared it with yours and the only difference is that Charley has a different kind of Unit Setup then you have.

Also, the problem seemed to dissapear when I add an gravity spacewarp and cranked up the values of both the wind and the gravity. No more flickering. :)

(Unfortunately I can't save the file as an Max8 version.)

10 October 2007, 01:32 PM
Thanks for checking the file(s) Wicked. I'm not sure why the system units would make a difference, since they are the same. Only the display units are different (displaying inches or meters or generic units). The actual system units are the same. We both had it set to inches.

So it shouldn't matter to display 1 inch, 2.54cm, 0.0253 meter, or 0.0833 feet, since the actual length/size is the same.

10 October 2007, 01:01 PM
Delete wind and gravity and make new .... work OK!

CGTalk Moderation
10 October 2007, 01:01 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.