LC #42 Pipers Alley

View Full Version : How to get game sprites to not antialias to background in MR?

10-04-2007, 04:49 PM

I'm rendering out 2D game sprites. If I use Maya Software renderer I can make the render antialias internally within the sprite but not to the [flat colour] background.
I do this by going into Render Globals > Maya Software > Render Options > Color/Compositing and turning 'Premultiply' off.

I can't find any way of doing this in MentalRay. Does anybody know how to do this?

10-04-2007, 10:23 PM
You'll find the premultiply toggle on the primary framebuffer section on the mental ray tab of the render settings.


10-05-2007, 10:24 AM
Excellent, thanks, I'll go try it now

10-05-2007, 01:15 PM
Bah!!! Turning premultiply off in MR sort of half works but I still get some background colour in there.

Any ideas what MR is doing differently than Maya Software in regards to the premultiply? I've tried all the different settings in the frame buffer section but nothing seems to work.

03-27-2008, 12:09 PM
Hi guys,
Just bumping this thread because I'm on my next project from when I originally posted (ended up rendering in maya software) but I still need to know this because now I definately can't use maya software for my current job but I need to not anti alias to the background.

Any fresh ideas?

CGTalk Moderation
03-27-2008, 12:09 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.