View Full Version : Satellite struggle again...

10 October 2007, 11:00 AM
I have my master machine with x64 Maya 2008 and as a Slave a MacPro running Windows 32. We switched off the Firewall, set the ports 7105 in the rayhost file on the master and in the services file on the slave, we can ping the Slave machine, but when trying to render we don't even get an error message - it just doesn't use the satellites at all, even for big and slow scenes.

Is anybody else using a similar setup or has an idea what the problem might be?

Thanks a lot - Christoph

10 October 2007, 04:59 PM
Did you try using other port numbers? im using it here 7107
Also, where is the mayarayhosts file located?
It needs to be puted in C:\Documents and Settings\USER\My Documents\maya

10 October 2007, 05:00 PM
Maybe I'm wrong, but I don't think you can mix 64 and 32 bit satellites.

10 October 2007, 01:10 PM
Thanks for the reply guys!
According to the docs it should be possible cross-platform (but not recommended)
I also installed the satellite on OSX and the x64 master picks that one up easier, but
we only got it to actually render only once - very weird. we tried 7107 as well...

It just seems to be such a temperamental thing to get it going - and sometimes it's just not happening:-(

10 October 2007, 01:28 PM
are you using any custom shaders? That could be what is up if you don't have the 64 and 32 bit versions of those custom shaders.

10 October 2007, 01:42 PM
In most of my scenes, yes, but not in the scene we tested.

Just default shaders.

Or do have to install onto the slave all the shaders you installed on the master, even if you aren't using them?

10 October 2007, 01:57 PM
Unfortunately Satellite is.. or at least was very unstable back in 8.0 and from what I gather isn't any better now. I remember it was extremely flaky and when one node wouldn't get info fast enough for one frame of one scene, the whole batch of renders would quit.

10 October 2007, 02:11 PM
In most of my scenes, yes, but not in the scene we tested.

Just default shaders.

Or do have to install onto the slave all the shaders you installed on the master, even if you aren't using them?

YES I have found this to be true, all shaders installed on Master have to be installed on slaves in order for the slaves to start.


10 October 2007, 06:39 PM

There is no reason to try port after port... If you're not certain about what port it is and you can't find it in the doc or if they misstyped it in the dock just look at:



Look at the bottom... There you'll find mi-raysat*.

8.0 defaults to 7105 and 8.5 defaults to 7106. 2008 ain't in my services file so guess it's using 8.5's port? Or something went wrong with my installation.

I have done tons of sattelite renders where Win32bit, Win64bit and MacUB have rendered on the same job. No problems really. Atleast not in batch mode.

Look on the mac and pc if the raysat is really running. On wintel the process is called raysatXXserver.exe. Don't remember the name of the Mac one. But try a:
ps -waux | grep ray

I think the ps command on mac takes all the waux flags. try it out.

edit: just remembered i never installed 2008 sattelite. Now I have installed it and it defaults to 7107.

10 October 2007, 02:25 PM
Soooo - I managed to install x64 on the MacPro and also installed all the custom shaders.
services file is 7107, rayhost file is also set to 7107, I can ping the MAc from the x64 master, the raysat server is running, double checked the IP address - seemingly everything should be fine, no?

But I get this in the renderlog:

// mental ray for Maya: using rayhosts file C:/Documents and Settings/Administrator/My Documents/maya/2008-x64/prefs//maya.rayhosts

Info: (mental ray) : adding rayhosts

Info: (mental ray) : adding host:

MSG 0.0 debug: mi_msg_add_host adding host, socket -1

MSG 0.0 info : adding new host 1 (

MSG 0.0 debug: WIN_NT: setting thread to non-overlapped socket operation

MSG 0.0 debug: WIN_NT: setting thread to default socket operation

MSG 0.0 error 011229: could not connect to host:port - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

MSG 0.0 error 011706: cannot add host

Funnily when I restarted the slave in OSX and we did another test it worked - without the custom shaders installed. Nice, but I really need the windows version to work because of the shaders I'm usually using an that are not available for OSX:-(

I've run out of ideas - anybody?

Thanks for all your help guys!

CGTalk Moderation
10 October 2007, 02:25 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.