XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Allan Mckay's fracture script help!

08-08-2007, 07:11 PM
I'm trying to do the tutorial on Allan Mckay's site using his fracture script. I can't get it to work at all, though.

I get this error: -- Argument count error: object create wanted 0, got 1

I don't know anything about scripting so I was hoping someone could give me a clue.


08-13-2007, 01:25 AM
You can send me the script and i'll check if it works.

08-16-2007, 09:01 PM
sorry I haven't replied earlier, just been busy. I'll get that to you in a day or two.

08-17-2007, 12:46 AM
You create your mesh. then run the script, then select target obj, set the options as you want them. then fracture.

If you do something wrong you have to close the floater and run the script anew.

I know you maybe did this... but just in case

08-22-2007, 05:09 PM
I cant get the birth script to work, says it has errors, what gives?

10-03-2007, 04:49 PM
If you're still playing with this please post the code in a code window here. Then list the name/s of the objects related to the script that you are using in your scene.

10-04-2007, 03:53 AM
I have been getting errors with this script from Allans tutorial also. I have included the script and am using his fracture script to generate the chunks. I get the pieces to go but they are not going quite right. I am including a pic of my problem.

I cant figure out why there is still geometery when the deflector passes thru. I have hidden mesh so it is not that. I am still learning and would appreciate any help:)

10-04-2007, 11:07 AM
I cant figure out why there is still geometery when the deflector passes thru.
Because in your flow you have a display-operator in both the events! :)

If you want the fragments to be a different kind of geometry, you should include a Shape (Instance)-operator in your second event.

10-04-2007, 06:22 PM
I tried removing the display from each event and it was not right. Alll I am left with is particles appearing when the deflector passes thru.

I am including a pic of what I am talking about btween the difference of allans result and mine.

10-04-2007, 06:27 PM
Ah I see..
You should hide your geometry in the scene. In Allans part of the screen all the geometry you see are just particles.

In your part the particles AND your geometry is visible :)

10-04-2007, 06:31 PM
Hiding the mesh was the first thing I did so it cant be that. I dont think it is the script. I am at a lost of why this is occuring.

10-04-2007, 06:59 PM
If I remember correctly you have...

1 original mesh
pflow fragments (particles)
...in your scene. Right?
If you hide the first 2 and then still have the same result as shown before, then there is something wrong about your scene. It should work :)
Care to share the .max file?

10-04-2007, 07:16 PM
yeah I hid all except pflow and have the problem. I can create a regular pflow and have particles move where they are supposed. The problem seems to be the birthscript event method. Here is a link to the file.


10-04-2007, 07:38 PM
I got this working right with Bobo's script from the tutorials on his website. I just changed the global variable from box to fragment to work.

on ChannelsUsed pCont do
pCont.useAge = true
pCont.useTM = true
pCont.useShape = true

on Init pCont do
global ChunksArray = $Box* as array

on Proceed pCont do
t = pCont.getTimeStart() as float

if t < 0 do
NumChunks = ChunksArray.count

for i = 1 to NumChunks do
pCont.particleIndex = pCont.NumParticles()
pCont.particleAge = 0
pCont.particleTM = ChunksArray[i].transform
pCont.particleShape = ChunksArray[i].mesh

on Release pCont do


Now I just have to go and figure out what the difference was between the two for my own education :)

Thanks for all the help and Thanks to Allan and Bobo for the great tutorials !

11-11-2007, 11:17 AM

Hello, i have been working on a project and have beent trying to get the fracture script to work. i have made it work in a single scene but for some reason i can make it work in my "real" scene. i use the exact same flow and script but it just dosent seem to work.
http://files.ckdpc.com/files/2/through_roof02_.rar <--- the file
you may need pen-attribute holder to open it part of the character rigs involved, or just skip it all its the glass in the roof thats having the trouble.

any idea's how to fix?

CGTalk Moderation
11-11-2007, 11:17 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.