View Full Version : Maya 4.5 linux viewport problems

03 March 2003, 02:42 AM
Hi All,

I was just wondering if anyone else has had this issue which I am working to resolve.

On one of my machines at home I am running redhat 7.3 w/ dual 1GHz pIIIs, a Quadro 2 Pro, and the nvidia 4191 driver. I've been using Maya 4 mostly, but I finally got around to upgrading to 4.5 recently - and ever since I've noticed that the menubar inside the viewports doesnt show up. The ones where you select 'panel' and choose what camera shows up in the view, camera attribute editor, etc. Not sure exactly what the problem is. Everything else shows up fine and there are no graphic anomalies.

I will try re-installing when I have a chance, just wondered if any of you had run into that with maya 4.5, redhat 7.3, and nvidia drivers...


03 March 2003, 04:18 AM
did you install the multi-processor drivers? if so try the uniprocessor ones and see if that helps. some systems have dramas with nvidia drivers under SMP.

03 March 2003, 06:10 AM
Have you tried looking through the qualified Linux systems ( page on It seems to be very specific about which versions of software you can use Maya 4.5 on. Quadro 2 Pro is only certified for RedHat 7.2 and not 7.3 so it may be necessary to downgrade if you want to resolve these issues.

regards, Paul

03 March 2003, 07:37 AM
IMHO official certifications are a waste of time. 9 times out of 10 software manufacturers only make a token effort, and always do so on hardware that's 12 months old.

if you're game, i'd try upgrading to the latest stable kernel and X-windows (if you haven't already) , and reinstalling the drivers. often with linux if you update one piece of software you need to update the lot.

03 March 2003, 07:56 AM
I'm already running the latest SMP kernel, X under gnome, and I used the kernel-source tar, so I dont think it's an issue of me having the wrong driver installed... I could rebuild it for UP kernel i guess, but I've never had problems in the past and all of my other apps are fine.

Just thought it odd and wondered if anyone else had the problem. No other menus missing, just that one. Maybe it hates my screen-res (1280x1024). I'll try some higher and lower ones and 1280x960 as well.

Come on fat bloke! I see you fixing other people's problems all day long! haha.

03 March 2003, 10:56 PM
Originally posted by amygdalae
Come on fat bloke! I see you fixing other people's problems all day long! haha.
hehehe :)

i have to say you've really got me stumped on this one! recompiling for UP would really be a waste just to get a video card working again. certainly try it out (you can always set your bootloader to boot to different kernels), but otherwise all i can suggest is downgrading to an older driver set. the 40 series of drivers is far more optimised for geforce/quadro4 cards with hardware pixel shaders rather than the older geforce/quadro2 style hardware that is limited to vertex shaders only.

03 March 2003, 11:42 PM
Have you tried moving your preferences out of you home maya directory and letting maya create new ones? Sometime old preference don't upgrade well to new versions or get corrupt. This doesnt sound like a linux specific problem with kernel, drivers, etc...

03 March 2003, 05:35 AM
Yeah, I was worried about that.

I had actually done a clean install of 7.3 on a new scsi disk, re-installed everything from scratch including maya, didnt load any of my old prefs, not even shelves and things.

Hmm. Might try the older drivers and a few other things.

No worries - just wondered if anybody had something similar happen. Odd.


03 March 2003, 08:12 AM
this page:

says this: Model Version Driver Settings
Quadro 4 980XGL(NVIDIA) Red Hat 7.3
1.0-4321 default settings

Limitations and Solutions
Limitation Imageplanes consisting of alpha only are not displayed correctly.
Solution None
Limitation There is a known issue with previous released driver (1.0-4191) which is otherwise suitable for Maya:
when using any other desktop manager "theme" than the default, the X-server may hang.
Solution Set the desktop manager theme to default.

don't know if that helps at all, but there's plenty of other stuff around there. i'm sticking with trying to drop back a driver version as a solution.

03 March 2003, 12:48 PM
I'll give it a shot.
Thanks elvis

CGTalk Moderation
01 January 2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.