View Full Version : rpf & format issues!?

06 June 2007, 10:06 AM
right, so I'm not a big expert in compositing, but I do try from time to time, I have a few sequences that needs Dof. I cant seem to get the rpf format options going upon import, frames are rendered in 3dsmax, all options checked, and just checked with help docs, one should get the options when importing rpf?? I simply cant import z-buffer only, says so in help doc anyway, I'm doing something wrong but what??

*edit, got it working somehow, couldn't get the import option..used a show G-buffer instead, but now a the "fake" blur/dof(by following G.M Davis example tutorial) is aplied I get slight alias artifacts around foreground background, how to eleminate thsi?

*edit again, nevermind, got rid of the alias arising from the show g-buffer, sticked a gauss blur onto it



06 June 2007, 10:15 AM
thanks for the tip with adding a gauss on the gbuffer.

If you use 3dsmax you could also render with almost no sampling but higher the resolution by 2 or even 4. So for example if you want PAL then you don't render 768 by 567 with a high filtering like 1/16 but you render 1536 by 1134 and then set the sampling to 1/4. You save time by rendering with less sampling, but of course sacrifice it with the higher resolution, but now you have "antialiased" gbuffers...

you could also use scanline which is capable of sampling them on the fly.

does anyone know a better solution for this?

06 June 2007, 05:49 PM
Render Elements > ZDepth > Enable Filtering. This will generate a seperate ZDepth pass with AA. There is a reason gbuffers aren't Anti-Aliased. For things like Object or Render Node ID if you have a Red object ID over a Blue Object ID and AA it then the overlap would be values between red and blue. Also, the gbuffers would require extra sampling. The best result is to do it with render elements or other render pass management tools, but you sacrifice accuracy for image quality.


CGTalk Moderation
06 June 2007, 05:49 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.