View Full Version : Mesh disapears when BatchRenderering..???

Big Piece of Chunk
06 June 2007, 07:49 AM
I have imported a mesh as an OBJ file to Maya from max.

Then rigged, lighted and animated it. the Test renders from the renderview works fine, however.

When Im Batchrender the animation all I get is Blank tif files The Render Log tells me

Error: (Mayatomr.Geometry) : unnamed object is not a mesh, ignored.

*How can I solve this problem . the Mesh is Poly and I even tried to rename all the part to see what could be the problem.

could this be cause of imported mesh or Early in the scene I played around with a Reference object to lock the down the textures ( however I seemed to erase it, cant find it or I have deleted it)

Help would be very welcomed.

Big Piece of Chunk
06 June 2007, 01:54 PM
The problem is that I have animated the mesh and now need to batch renderit out.

Is there a way to apply the animation & deformers to a duplicate mesh.

ARGh. Is there anything wrong with the mesh or with mental ray I dunno ????

I guess I could save all the 300 frames manually from the renderview.

06 June 2007, 03:11 PM
MR is a gourmet when it comes to meshes. It might aswell be some tiny problem with the that. Do a cleanup before. My usual reply, almost like telling to reboot by now:)

You can aswell try graph it in the hypershade. When you seperate meshes you can a hidden shape within the mesh that isnt connected anywhere, which for certain applications like various exporters (pehaps MR aswell) isnt accepted. If you find one of those, just delete it.

If you need to clear some history, theres of course multile approaches. Saving and reloading skinweight, or using subsitute geometry to replace with a healthy mesh. Perhaps just step through one at the time, delete all by type history and try to render, if it works, your one step closer.


Big Piece of Chunk
06 June 2007, 07:26 AM
The mesh isnt skinned at all, its just a speaker-element wich, has bend squash & twist deformers applyed on it. The Obj. mesh is from 3dmax then saved in maya the animated . It does render in the renderView with & without MR. However when Im trying to Batchrender the scene the mesh dissapears. and the error message comes up in Renderlog

Error: (Mayatomr.Geometry) : unnamed object is not a mesh, ignored.

what's the unnamed object how can I find it. and DELETE it

Is there a way to try to import the mesh again and the use the deformermers save the keyframe data and the apply it on the new mesh.

(Sverige för EMguld och håll slåttet i London)

06 June 2007, 08:29 AM
Try turning off

Render Settings > Mental Ray > Translation > Performance > Optimize Animation Detection

Had a similar problem 2-3 months back when i used blend shapes / nonlinear deformers / lattice to deform a model. However, my model was created completely in maya. I think it had something to do with the various deformation sets that my model was being linked and unlinked from to get things just right.

Good luck

06 June 2007, 11:22 PM
If you do a batch does it render the first frame of the batch but black after the first frame?

Big Piece of Chunk
06 June 2007, 07:41 AM
hello dear companions..

Razor back thanx for the reply I will try later today . What I did was to save everyframe manually from the renderView and renamed them 001,002... it worked however it took foreverver.

andrei the frames from Batch render came out blank all of them. no information at all..

This problem had nothong to do with mental ray I suppose since the same problem accured whn ebstch rendering with maya software render as well....

C u and thanx for the replies

06 June 2007, 08:17 AM
Try duplicating the mesh and exportingit to FBX and re-importing it into maya and save out the "clean" mesh.

Bake the animation on the "problem" mesh and then transfer the animation to the clean mesh.

Big Piece of Chunk
06 June 2007, 12:15 PM
could you please explain more in detail.

FBX and how to bake the animation and to transfer it..


06 June 2007, 03:16 PM
turn on your fbx plug-in and then export to fbx format and reimport. usually it fixes any issues meshes have.

Edit>Keys>Bake Simulation

Look in the help for what the different options mean and which you need to turn on.

Then turn on ANimExport plugin and export animation from one mesh and import to new mesh.

06 June 2007, 01:41 AM
Razor back thanx for the reply I will try later today . What I did was to save everyframe manually from the renderView and renamed them 001,002... it worked however it took foreverver.

I feel your pain. I wrote a script that actually automates rendering from the previewing window into an image sequence a couple years back. At that time there was a certain simulation software that allowed full preview renders but blocked batch renders. And we were broke at the time....

I'll look through my archives and see if i can find it. If I do i'll post it here.

Big Piece of Chunk
07 July 2007, 04:05 PM
Thnx again for all the help . I will look in to the baking of animation. Seems sweet.

Anyhow . Again the same problem is accuring . ???
On a different scene .
The strange thing now When batch rendering Tiff images its blank ,BUt
when rendering out iff images it works fine.

Is there any explonation ?????

mental ray for Maya 8.5
mental ray: version, 22 Nov 2006, revision 19663
mental ray: mental ray for Maya - startup done
File read in 0 seconds.
Result: X:/logoanimations/Loggapingpong/scenes/testlo__3824.mb
mental ray: got 8 satellite CPUs.

This is the only text 'i get from render log .Very strange

Big Piece of Chunk
07 July 2007, 09:24 AM
Does anyone know why Maya's batch renderer cant render out tiff images, but tga, and iff. pretty sure the rest of the image files works fine.


11 November 2007, 12:54 AM
I've had the same problem.
Do a render from another camera, if that works then use a new camera and delete the old one.

11 November 2007, 05:55 PM
hey dude, if it's not working use this life-saving script for rendering multiple frames out of maya ( (

bad thing about is you're just able to output common fileformats (tif, tga, ...) i think just 8bit

anyone knows if there is a script to render out multiple-frames .exr (16 bit or higher) out of the renderview???


CGTalk Moderation
11 November 2007, 05:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.