View Full Version : (help!) hardware render with motion blur

06 June 2007, 12:21 AM
I am confused that the hardware rendering with motion blur doesnt work as I expect.
If I disk cache the particles, there wont be any motion blur at all.
If I memory cache the particles, things are still weird like some have moblur, but some dont.
So what's the correct pipeline to do it?
Could anyone help me out? I've been troubled by this for a long time:shrug:

06 June 2007, 09:40 AM
To use motion blur in either hardware render buffer or Maya hardware renderer you have to first create a particle disk cache or memory cache. Then go to your multi pass rendering options and check multipass rendering. The Motionblur controls the amount of frames the blur is blured over, and the render passes controls how many times it renders those particles over that frame range. Also make sure that your samples setting is always at least one number higher than your render passes otherwise you will get wierd results. I hope this helps.


06 June 2007, 02:11 AM
Hi James
Thanks a lot for the reply.
That's what I suspect. The pipeline should be easy. But somehow I have this weird problem.
Sorry I didnt describle in detail.
It's like when I use disk cache, each sprite particle has only 2 images for the beginning and end frame of the blur period, instead of having several passes of blurry images.
However it worked twice (I got blurry sprites) when I turned on disk cache.
That's weird right?
Then if it failed, I'd try memory cache. It worked if I render view for a single frame. If I try to render sequence with xframe(mel script that saves render view in a sequence), the beginning frames would work , but there would be several weird particles that move every other frame without motion blur for the later frame. (and then there'd be a pink message says particles may not evaluate as expected. But I have tested that they work previously :<)

So I have to compromise to composite those weird particles out.
If there are few particles, it's ok, if there are numerous, it's crazy.

And that's the problem, I still cant figure out why sometimes it worked, sometimes it didnt.
Any idea what I have done wrong??
Thanks again!!

06 June 2007, 06:05 AM
Can you email me your scene file so i can take a look at it? I will be able to get a better idea of what you are encountering. Please send the file to and i will take a gander at it. I hope I can be of some help.


CGTalk Moderation
06 June 2007, 06:05 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.