View Full Version : Vue 6 on Vista

05 May 2007, 03:23 PM
I am running Vue 6 Infinite on Vista. I have not run this on XP so am looking to see if my issues are Vista specific.

The problem is the OpenGL performance in the viewports is horrible. Any changes I make in a single viewport take a few seconds to refresh in the other viewports, especially in the main camera view. And dropping all my meshes to cubes while moving them is very distracting and very difficult to place things.

I have tried to play around with the Instant draw settings in the options but have not found a good solution.

I am running a Core Duo with 2 Gb memory and a nvidia Go 7600 video card (all latest drivers) so I should have plenty of horsepower.

I have no trouble working in the Softimage XSI viewports but Vue is like working with a graphics application from 1995. Move and wait, move and wait, move and wait, etc. And it is all but impossible to get any kind of accurate placement.

Anyone else experiencing this? Are Vue 6 viewports just as poor running on XP?

05 May 2007, 02:22 AM
Hi Michael,

I had this problem aswell, with vista...I downloaded the nvidia forceware driver from the nvidia site (I could be wrong with the name of the driver...will confirm this when I get home.) Anyway it fixed everything, But I decided to go back to xp...

I will get back to you later with the exact name of the driver.

05 May 2007, 02:46 AM
Thanks Ivan,

Since I'm using a laptop video card, I don;t think I'll be able to use that driver though. I think laptop drivers are only provided by the laptop manufacturer. At least that is what I found at the nvidia site.

I have only been using Vue for 2 weeks and I am more and more impressed by the quality of work I have been able to accomplish in that short time. The ecosystem feature is stunning in it's capabilities and I love the wind and breeze effects on the plants and trees.

Having said it's praises I am disappointed when working with Vue because of the poor viewport interaction. Maybe it is something I need to get used to since I am so engrained with XSI.

First off, I don;t like the 2D style bounding box that Vue puts around selected meshes.

Second, I feel like I am gambling whenever I edit a precedural terrain since the result I get in the viewport only vaguely resembles the terrain I painstakingly edited in the terrain editor, even after adjusting the size. I would find it impossible to create a scene containing Ayers Rock, the Zugspitze or the Matterhorn because I am unable to acheive that level of control on the terrain editor. So I play hit and miss in the editor until I find a result I like.

What is especially annoying this evening is that I am trying to sculpt a cliff in an entire mountain side by using the Raise brush. This does create the cliff but it also smooths the mesh where it was raised so I loose that gritty detail. I have been going in after the Raise and brushing the effect back on but I find I have to cover the entire mountain not just the raised cliff because I cannot exactly replicate the original style of that gritty detail.

But then again, I do realize that Vue is by no means a modeling app, even for modeling terrains. So perhaps experimentation without explicit direction is the intention of Vue's terrain editor.

05 May 2007, 03:28 AM
It sounds like your having more of a videocard driver issue. I've DL'd and installed the newest Nvidia drivers for Vista, and they suck. Talk about screen glitches in WoW.
Anyways, head on over to and download I THINK v.100.15 vista drivers, they seem to give me almost no problems.

05 May 2007, 08:10 PM
I have been having the exact same problem

I am running a Dell DualCore but with an ATI X1400.

I have 2 of the exact same system and both of them were haveing the same problem you are. I downloaded the latest drivers from both the manufacturer and a Windows Vista Update that had an optional ATI driver update. So I allplied both.

It worked fine on my wife's system, but did nothing for mine... so go figure.

I would say try finding latest drivers from both the manufacturer AND seeing if Vista update has one that may help. Uninsatll ALL drivers and starting from scratch.

A big part of the problem has to do with Vista being a little bitchy bitch about not wanting to support Open GL and emulating everything through DX10. However enough people complained so they added support in the end, but I guess it is either still buggy or MS just does not care.

05 May 2007, 08:14 PM
PS - As to your terrain issues.

I rarely use the internal terrain edtor for precise things like that. Try creating a map in Photoshop to get that edge and then use the editor to detail it.

05 May 2007, 04:01 PM
Is there anyone else currently on Vista having similar problems?

nVidia or ATI?

05 May 2007, 09:02 PM
I have it on one XP machine and one Vista machine. Open GL performance is not to hot on either. The promo material before the pre-release said this is a core rewrite but the same issues I had with 5 seem to live on. I do not think it is even recognizing ready boost which gave my other software a little boost. Its reporting the right amount of cpu's on Vista but the performance makes me think its not really advantaging it. My Vista machine should have given it a large performance boost but no joy. The Open GL performance on all other software is perfect. Only Infinite is having trouble. Same thing on XP. In my humble oppinion its the software not the OS.

Anyone have any info on a graphics card that works with this? I have a couple that are on their list but no joy. Lousy performance. Latest drivers don't help either.

05 May 2007, 10:29 PM
i had the same problem with a shoddy OGL view.. was running vista 64 with an ATix1300...

now i got meself an Nvidia 8800 GTS with latest forceware, works great now.. guess its a directx thing..



05 May 2007, 02:46 PM
go to option/option display/unable openGL(software)

05 May 2007, 12:46 AM
I don't want to disable Open GL. To tedious to work in wireframe. My system exceeds the requirements. My graphics cards are on the list. Same problems on XP and Vista so its not a problem on this end causing it. I'm not sure how well the card manufacturers and software developers work together but I'm sure its vital to performance that they have a good relationship. They will work it out I'm sure. I'll just keep updating the drivers.

About Vista. Got it running a lot better today.
Go to the .exe file (usually in the Program/ folder).
Right click and select Properties.
Click on the Compatibility Tab.
Check Run as administrator.
Choose the XP compatibility mode.
Click on the all users button and do the same.
Now it is running much better and opening imported files.

05 May 2007, 08:42 PM
For me its only a Vista Problem as I have 2 other machines running XP and it not a problem.

In the end for me, I switched from Hardware OpenGL to Software OpenGL in the options. It is still not like it should be, a little sluggish, but its a lot better and more accurate.

I dont know what the deal is, all I know that on the average, Vue should be a MUCH stabler peice of software. It has amazing capabilities and potentioal, but I sinply do not have much confidence in its ability to produce on demand on a consistent basis.

05 May 2007, 10:24 PM
About yu terrain: The raise tool does indeed wash out details, but you can add details back using a brush image to paint small details on the cliff you just created.
Procedural terrains can be a bit of a gamble, unless/until you know well your fractal noises.
About OGL, I have Vue on home PC and laptop as well, and I had to update my drivers to get Vue6 to work properly on it. But it's true you need to check your manufacturer's update pages for this. Mine had the newest drivers available, and it made a huge difference. Did you check yours?
Another very sensitive parameter for openGL in Vue is the instant/background draw thread sliders. Play with them and see if it gets more responsive.Too high a background draw thread, and the interface will lose responsiveness.
You talk about black boxes. Vue only displays in "filled" or "wireframe box" if you told it to, because "smooth shaded" is on by default. Maybe you allowed compatibility mode at some point after a crash, and the compatibility mode settings are still applied.

CGTalk Moderation
05 May 2007, 10:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.