View Full Version : material problems

04 April 2007, 03:23 AM
go some issues with materials :
im applying with a "mateial static" my mat to my particles, everything works fine until i use a a gradient in the diffuse slot of my mat, when i try to render it says to me : missing map coordinates, "the following objects require map or not may render". but if its a straight mat with no gradient in the diffuse slot, it works.

other problem on one of my event i ve got a fire mat, and when i try to render i ve got a "continue or quit without saving" error pointing me to "point3.h , line 196" for the error
any help ?
sorry again for the crappy english


04 April 2007, 05:31 AM
You will probably have to post an image of your flow. But the first problem may get solved if you drop the Material Op below the Shape Op.

04 April 2007, 09:45 AM
had already the mat below shape, anyway i made a pic for the first prob :)

edit : it seems to be something about the coordinates of the gradient, when i switch from explicit map channel to anything else it works/render without the error dialogue ( except vertex color ), but the result is not what i want, i want each particle to be shaded by the mat as it s been represented on the mat viewer when the gradient is set to "explicit map channel"
thanks for any help :)

04 April 2007, 04:57 PM
Hmm, I guess I didn't realize that the standard Shape Op doesn't carry mapping. You may get the result you are after by turning on Face Map in the Material Editor. Or, if you have PFToolsBox1, use Shape Plus Op, it has a mapping checkbox. If not, can always use a Shape Instance with an object that has mapping applied.

I cannot tell what your second problem is, for that you may have to post a scene, or at least the flow of that part.

04 April 2007, 02:52 PM
oh tnanks it works :), for my second problem, i know where it come from :
it s from the opacity setting of my material, when i set the opacity to 100% it render correctly, but if i decrease the opacity ive got a "continue or quit without saving" error message when rendering.

04 April 2007, 02:56 PM
Is this the scanline giving the error?

How many particles are in your scene and how much RAM do you have?

04 April 2007, 03:51 PM
30 000 particles and 1gig ram
yep it's the scanline wich give me the error, hers the pic, and it seems that i have an other prob, i ve got 4 events : fire, smoke ( with AB ), ashes and embers. they all work when switched alone, but when i ll turn all of them on, the fire events won't render, i see my particles in the viewport but they diseaper in the render, but when rendererd alone it works...

sorry again for the noob questions :)

04 April 2007, 06:38 PM
Hmm. It might be a memory problem. Watch your system RAM with the Windows Task Manager and see if you exceed 1GB. Can you post a scene file. If you are uncomfortable posting it publically, you can PM me and I will send you my emial.

05 May 2007, 02:18 AM
hey i got the same error. when i set the opacity to 100% it render correctly, but if i decrease the opacity ive got a "continue or quit without saving" error message when rendering. anyone know how to fix it . thank you

06 June 2007, 05:21 PM
I get the same error all the time using particle flow...First I thought it has something to do with afterburn...But it still comes up in scenes without afterburn...I just hit "don't show this again" or whatever and continue...doesn't seem to cause any harm to the scene...But would like to know what it's all about...

CGTalk Moderation
06 June 2007, 05:21 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.