View Full Version : errors going into maya

04 April 2007, 03:58 AM
hey everyone, I'm tring to import things into maya 8.5 from MB 7.5. I'm trying to do the exclusive merge but when I do it gives me a "fatal error". This is if I've only ploted the animation onto the skeleton for the characters. I tried going to the top and plotting all animation properties and when I go to put that into Maya it doesn't give me any animtion at all in maya. When I do a regular merge in maya things seem to work. I was wondering if anyone new why this is happening or how to fix it. Thanks

04 April 2007, 12:28 AM
Hey. Have you tried adding them into a new scene? I know Maya can get kinda funny with the merge options. Also, do you have the latest version of the FBX plugin? Just a thought. Sometimes its the simple things that fix it.

04 April 2007, 06:12 AM
Yeah I have done new scene merge. The thing is for some reason one of the characters is a little funny in Motion builder. The jaw joint doesn't seem to want to scale when I scale the control rig and I figured that doing an exlucsive merge would fix that problem. I have two characters in the scene and both are set up the same with the same kind of skeleton. One has no problems when using the control rig. The other though has the jaw problem. I've checked to make sure that they were the same a bunch of times and haven't found any differences between the two. I'm pretty sure that the fbx is the most up to date, because it's through my school and they are normally up to date. If anyone has any idea's let me know cause I've been trying to figure this out for about a week now with no luck.

04 April 2007, 05:11 PM

in your mB scene, do you have 2 characters in the same a battle or something?
you might try to import .fbx file to one character at a time, then import both into a new scene in Maya.

the "jaw problem" is an aux joint in mB, correct? the problem is in mb or is it apparent only on your rig in maya?
when I have issues like that it usually starts in maya.

It would help out if you could post some pix of the issues in mB and maya. Fatal Errors suck.

04 April 2007, 05:14 PM
hey, Thanks for taking a crack at it. Yes I do have two characters in a scene because thats what it is is a battle. I have tried exporting each character seperatly but it still gives me the fatal for each one. It doesn't give me the error when I do a regular merge. As for the jaw issue it starts in MB and travels over into maya. In MB it just won't scale with the rig. If I don't scale the rig and just merge it into maya it ends up crooked. Currently at a school computer without the file scene but I'll post a screen shot later today. The strange thing is that the other character doesn't have this problem and I have them set up exactly the same way in both MB and maya. I've checked all the input and output graphs in maya and checked the rig set up in MB. Also another strange thing is when I do an exlucive merge in Maya 7 it works almost as in the character comes in and has motion but the joints and mesh are so messed up it doesn't even look like a person. The legs are turned upside down and the arms are flailing all over the place. I've been trying everything I can possible think of. I was wondering if maybe I did the exclusive merge on a Linux machine if that might make a difference. Thanks for the help cause I've been trying to figure this out for about a week now. I'm the first person at my school to really do motion capture so the teachers are learning it at the same time I am. Any help would be GREAT! Thanks again!

04 April 2007, 04:01 PM
If you dont mind me asking...what versions of MB and Maya are you using? I get the same results when I use MB 7.5.1 and try to Exclusive & regular merge to Maya 6.5 . I'm not too sure why it does this and I've actually posted on here about the problem, no answers as usual. My workaround is I work in 7.5.1 when I need to, open it in 6 then import to Maya-perfect. I think it's a skin weights issue. Does it go a little nuts when you activate the control rig as well? I have a character who ends up looking like stretched out gum when I activate the control rig...weird.
I have also had the same issue with fatal errors. My reason was because I wasn't "cleaning up my scene" before I exported. I delete everything except for the reference nodes and the joints. I'm guessing you might have blendshapes? Try my method to see if it works, of course dont overwrite your original file :eek:
I hope this helps some. Keep me posted.

04 April 2007, 10:44 PM
Hey, Thanks for the replies everyone. Favian001 I'm using maya 8.5 and motion builder 7.5. The funny thing is I just fixed the problem by moving back a step and using Maya 8.0. That seems to work perfectly.

CGTalk Moderation
04 April 2007, 10:44 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.