View Full Version : Verticles not working properly with skin

04 April 2007, 10:47 PM
So I've skinned this model and have had some problems with it along the way, but I finally managed to get everything working thanks to helpful people around here. Then of course, another problem pops up...

I've assigned some verticles to a bone with a weight of 1, so it should follow that bone entirely, but unlike some nearby bones with the same weight (1,000 to the bottom lip bone), these four verticles don't follow. The shots are taken from the inside of the mouth, the first shot is the default pose, the second a posed one.

I've tried resetting the weights for those verticles and both repainting them as well as assigning them to the bottom lip bone with the component editor but either way causes this.

I've done a lot of mirroring and loading verticles from weightmaps because of a problem I had earlier, but this only seemed to start showing up recently.

If anyone has every had a similar problem or knows of a solution I'd love to hear it. Thanks in advance!

04 April 2007, 05:02 AM
Does the geometry have any deformers applied on it? If so check the deformation order.

Additionally, try selecting the skinCluster node for the geometry and invoking the edit membership tool. Try to see if the said vertices are higlighted along with all of the other vertices in the skin cluster. If not, they might not belong to the skin cluster, shift select them while the edit membership tool is still active.

Also, when you move the root of the joint hierarchy, do these vertices stay behind or do they follow? If they follow, they're probably still weighted to another joint and that joint could have it's hold weight option set to on in the component editor, hence it's weights aren't getting transferred when you reassign weights. Turn off hold and reassign them to the desired joints.

04 April 2007, 02:27 AM
Hey, Verticles....that is a great name for a character....the long, lost brother of Hercules....

CGTalk Moderation
04 April 2007, 02:27 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.