View Full Version : Dielectic Trace Depth Problems


Synthesizer
04 April 2007, 02:32 PM
I've got some objects with a dielectric material applied. They are arranged in such a way that it seems the trace depth is broken no matter how high I set it. In the image below, I have it set to:

Reflections 200
Refractions 200
Max 400

And it appears the same as at 2, 2, 4. I don't mind it on the blue objects, but what is happening to the yellow object really sucks. Does anyone have an idea of what to do for this?

bgawboy
04 April 2007, 03:23 PM
I can't tell from this image how your scene would benefit from higher trace depth than 2 2 4. Is there more than 1 layer of a dielectric that we are looking through? What is your dielectric material's index of refraction?

KungKrille
04 April 2007, 10:23 AM
I donīt think your dielectric materials are transparent.

Synthesizer
04 April 2007, 08:55 PM
The objects are just cubes with beveled faces as in the example below. When I deleted the bevel on the backside, it got rid of the red stuff, but I still get some black areas on the corners. The IOR is 1.5 for all the materials. I'm assuming this is all just because of the shape of the mesh.

I don't see how a dielectric could not be transparent, I haven't set the colour to black...


http://img401.imageshack.us/img401/1009/beveledboxdi3.th.jpg (http://img401.imageshack.us/my.php?image=beveledboxdi3.jpg)

CGTalk Moderation
04 April 2007, 08:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1