View Full Version : Holy crap FXLinker is a piece of crap.

03 March 2007, 04:23 PM
All I want is a spray of debris right? Modeled a chunky bit, made the particle emitter behave the way I want, saved the particle motion (Bolded so people won't say "did you save your pfx file?) and run FX linker to attach the debris object to the particles.

Looks exactly the way I want it in the preview.

Render, and they randomly blink in and out of existance every other frame.

F9,advance frame, F9 gets 2 different results. I've been slamming my head against the desk all morning with this and I've about had it. What the living hell is wrong with FXLinker?

03 March 2007, 05:41 PM
hmmm, which version of LW and which FXLinker, the new one or old one?
strange that it looks right in preview but not render...

what does a VIPER render look like if you render some HVs... just a first thought to make sure the pfx are correct...

hmm using MB in the render? cant rem this ever happening...
are you rendering on one machine?
if not, the farm reading the cache right?

hmmm... guess post the scene?

03 March 2007, 06:07 PM
It's lightwave 9.0 as installed, no 3rd party plugins. The FX linker is the one that is displayed on the left when the "Dynamics" toolbar is selected.

The campanion scene, which uses the same particle emitter, but has HV on the particles works perfectly.

I cannot post the scene, as I am on a heavily firewalled network on an air force base.

Both farm and a local (F10) render screw it up. Frankly I'm pissed off now, having wasted another hour of my day with something that should be working.

03 March 2007, 06:21 PM
Sorry for asking stupid question but did you hit CALCULATE / START button? AFAIR if you only hit play that's aproximation of particles but to have them properly working you need to calculate them first. Just and idea.

03 March 2007, 09:04 PM
Honestly, I don't know what was going on. I finally rebuilt the scene from scratch... and it worked. Naturally.

Triple G
03 March 2007, 12:52 AM
Just out of curiosity (and I know it's a little late now...sorry)...but by any chance could Full Scene Parameter Evaluation have gotten accidentally turned on? I've had scenes where I've beaten my head against the wall trying to troubleshoot them, turns out this has been the culprit on several occasions. Just a thought... :shrug:

03 March 2007, 02:43 PM
That was a good though, I went back to the older scene to check. (Yay incremented saves!)

Nope. Near as I can figure, there's just something wonky in the FXLinker for that scene. Assuming it's one of those random things.

03 March 2007, 02:48 PM
what happens if you take the wonky scene, dont rebuild from scratch but simply kill all the fxlinks and then relink? still screwed up?

Triple G
03 March 2007, 05:14 PM
Or maybe you could open up a blank scene and do a Load From Scene with the wonky scene? That's worked for me once or twice...

03 March 2007, 06:46 AM
OMG, Russ Isler.

How did you end up in Northrop Grummen? Seriously.

I'm still chillin @ Eden.

Please tell me your still planning on opening the Snowtop Mountain red meat and Beer palace.



CGTalk Moderation
03 March 2007, 06:46 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.