XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : Help (or have) a good car window shader?

03-03-2007, 06:31 PM
I've been trying to get a good car window shader working, and not having much luck. Does anyone either have one they can share or can help by suggestion how I should build a render tree? This is what I have right now, which is not working well at all. I'm not even sure where I got this from...


Any help is appreciated!


03-03-2007, 07:09 PM
Check out L_Glass plugin. Not sure how it is for car glass, but I've read many people hear saying that it works well.

good luck


03-03-2007, 07:42 PM
Any idea where it can be located? I'm coming up empty or with dead links on searches.

03-03-2007, 08:02 PM
Take this link :

Sorry about language .. but the download label in english .

03-03-2007, 08:23 PM
No problem! Was able to download it and install it successfully. I downloaded the example scene, (i see the glass-air in the material) works fine, looks great.

Now the dumb question - where do I get the shader from once it is loaded? I looked through the nodes and do not see it - do I access it some other way? Probably obvious but never used one like this before...

Boy I wish I could read Arabic (? if that is the right language) looks like a lot of great stuff on that site!


03-04-2007, 04:27 PM
Ah yes this one foxed me for a while also, Most plugins and shaders you install go in your users folder you will find them there.



03-04-2007, 04:39 PM
For custom shaders try the "more..." option at the bottom of the drop down menus.
Sometimes the shader shows up in the folderlist, if the one who programmed it added this into the shader, other than that you have to browse for it, and/or create your own preset in a little toolbar for easy access.

Oh... and find the "glass" thread on xsibase, there are some good examples on there. No need to go for L_Glass for a windshield I guess. Too much overkill IMHO.


03-04-2007, 05:10 PM
Now the dumb question - where do I get the shader from once it is loaded? I looked through the nodes and do not see it - do I access it some other way? Probably obvious but never used one like this before...

Ya as giant551 (http://forums.cgsociety.org/member.php?u=171820) said :
the path on my pc
C:\users\My Desk\Softimage\XSI_6.0\Data\DSPresets\Shaders\Material

Boy I wish I could read Arabic (? if that is the right language) looks like a lot of great stuff on that site!

thanks .. btw take this link it's translated to english by google :
Main Page:

03-05-2007, 06:49 PM
You should look into setting up a workgroup. Then, you can install all your custom shaders, addons, plugins, etc in 1 central location and have all your versions of xsi point to it.

03-05-2007, 06:54 PM
Yeah, I saw something about workgroups somewhere, and it sounds like a good idea. Does this mean I would have to uninstall any addons or anything I had previously installed first? That's the other thing too, I've installed addons that I have no idea where the heck they even are. Love XSI, but there are some maddening things about the UI.

03-05-2007, 09:10 PM
well.... unless you want all your plugins, shaders etc. showing up twice, you should uninstall all previous ones, and reinstall everything into the workgroup again :D

All previous installed plugins, shaders etc. should be found in the File>plugin manager. Uninstalling from there should be fine. All your stuff is filed under the "user root" folder. Or just browse the tabs. Also a "workgroup" folder is there when you created one, posting all your installed stuff.

You could also delete files by hand from your XSI user folder, but that might be tricky though unless you know where to look for files.


03-05-2007, 10:22 PM
Ok, removed the old stuff, made a workgroup, added the SPDL in my workgroup. I must be extremely dense, but I cannot find any "user's folder" anywhere in XSI (I am using version 6).

If I go into the render tree, select nodes (say illumination) and click more... even if I browse to the workgroup, it doesn't show up.

I searched the help files for user groups, but nothing comes up...sorry to be a pain but I just still don't get how I access this shader (is shader even the correct term?)

03-05-2007, 10:39 PM
xsi user folder:

when you install a shader, have a look in the default path the shader is using, that's where yoiu find it after installing. or run a search....


03-05-2007, 10:46 PM
Also make note of the "Paths" button, when you click the ... to search for stuff. That can help you navigate around, to User, to Workgroup, etc.

03-05-2007, 10:56 PM
Right - I know where I put the files I just installed, if that is what you mean. What I mean is, when I am *in XSI* modeling, and I hit the render tree, and I want to add the glass shader into my tree - from that point I am stuck. If I am supposed to click more and browse for it - which "more" am I after? Nodes > ?? Or not nodes?

Am I making sense with my question or I am totally barking up the wrong tree?

I mean from a user's perspective, you would expect a shader, once installed, to be available with everything else in the same place. I'm probably just not getting how everything is organized in XSI. I still have no clue how to acess addons either after they are installed.

You would think this would be clear in the XSI manual, but it isn't at least not to me.

03-06-2007, 03:45 PM
I don't have XSI in front of me right now. But generally when working with shader plugins, there are two ways to access them.

First of all, it's best if you know what type of shader you're dealing with. I guess that in the case of L_Glass it's an illumination shader.
Therefore, in the render tree you click: Nodes->Illumination->More... and then on Paths->User

If L_Glass is indeed an illumination shader (I'm not sure) then you should now already be in the correct folder. If not, back up one folder and dig through the other available shader folders.

Addons (*.addon as opposed to *.spdl + *.dll) are easier to access. You start by clicking on More... in any of the nodes menus, just like before. Click Paths, also like before, and all your shader addons should be listed in the menu. If you click on the addon name It'll throw you directly into the relevant directory.

03-08-2007, 01:17 PM
Okay, I finally got to it after choosing Node > illumination > more, then going to my user preset (i initially thought it would be in my workgroup) and found it. Thanks!

03-08-2007, 03:59 PM
Workgroup\Data\DSPresets\Shaders\Material is where my l_glass.Preset is. I think it depends where you choose to install it. Make sure you specify to install it to your workgroup. It doesn't happen automatically and you can't drag/drop to install stuff... I believe you need to select workgroup after you browse to the xsiaddon before install. Same with others.

CGTalk Moderation
03-08-2007, 03:59 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.