View Full Version : shake for linux installieren

02 February 2007, 02:21 PM
hi guys,

i am on a german school for 3d arts. there we got shake to learn (we had to pay for it) and now i wanna install it on a opensuse linux 10.2 - system. the problem is how to install shake 4 for linux. i have a shake-folder with a lot of subfolders in it. one of theses folders contains some execute-files (*.exe) which is a microsoft standard, not a linux-standard. all the other files are more or less c or c++ script-files but i can't install it. what did i do wrong? does anybody know how to install apple's shake on a opensuse linux 10.2 system?

thank you for your help.


02 February 2007, 07:49 PM
There is no installation. Just untar the file into wherever you want your app to lie(/usr or /usr/local is a common location). Now just run shake "/usr/shake/bin/shake".

02 February 2007, 08:41 PM

my problem is: i untared shake then i had a shake4-folder. this whole folder i copied in my homedirectory (/home/bluerose): there are about 7 folders insider my untared shake4-folder. in the bin-folder there are some *.exe-files which i really can't open with linux. if i try to start shake or tshake a texteditor is gonna open the file and shows me a c or c++ script. in all the other folders are *.h - files (c or c++). i cannot open those files.

maybe it is because i copied shake in my homedirectory? i first untared shake4 on my microsoft-windows-xp system (which is on the same harddisk like suse linux). then i started linux and there i copied the untared folder to my homedir.

02 February 2007, 09:26 PM
You should put shake in the /usr directory. Why are you trying to open exe files and .h files? Just run the shake executable(shake4/bin/shake, not shake.exe). Also add the shake bin folder to your $PATH so you can just type "shake" and it will run. Search the web on setting the $PATH.

02 February 2007, 10:15 PM
hi beaker,

this was exactly my problem. i already tried to start shake (/bin/shake) but it was a SHELL-script. a texteditor opened this script ( c- or c++ script ). but shake didn't start.

therefore i went back to the tutors of my university. they gave me a new version. i tried the new version a few minutes ago. now it works. strange.

thanx for your help

02 February 2007, 10:58 PM
You can't double click on it from the gui. You have to actually execute the shell script from the commandline. Also make sure it is executable in the first place.

CGTalk Moderation
02 February 2007, 10:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.