View Full Version : problem with move tool and mouse movement


bunnyld
12 December 2006, 05:16 PM
hey all

i have a strange mouse problem

the mouse is not acting right.

1) when i'm selecting an arrow in the move tool - i can select only the X axis, no metter if i highlight the ather axis with the mouse icon.

2) when i use the tool, i have to move the mouse left and right so the move tool will act up and down, like strange invert mouse.

i use ver 4.0, WIN xp. all drivers are up to date.

is that a known bug ?

thanks for reading.

norvman
12 December 2006, 05:22 PM
no definately not a known bug...

I have 4.2 installed right now (waiting on my 6.0 to get shipped here) and I've never seen anything like that before...

:shrug:

MJV
12 December 2006, 06:28 PM
It sounds like you have locked an axis. If you double click an axis it becomes locked and only that axis will transform. If you double click it again it becomes free again. You can turn this behavior off in preferences.

bunnyld
12 December 2006, 06:53 PM
all the 3 axis are in use, no one lock. still the problem continue :\

tachy0n
12 December 2006, 02:20 AM
In prefs there should be an option like 'Move along cursor direction'

Make sure that's enabled (sorry cant be more specific, i dont remember what the v4 prefs look like)

bunnyld
12 December 2006, 06:32 PM
i make sure that box is check, but it's the same. no change.

also try to check \ uncheck all the boxs there... but nothing helps.

norvman
12 December 2006, 11:08 PM
couple of questions...

does the mouse do this in any of your other sceen files?

try a new sceen... can you select all the axis now?

Also... do you have any constraints or expressions on the object you are trying to manipulate?

:banghead:

luceric
01 January 2007, 01:57 AM
bunnyld, are you a new user just starting with XSI 4.0?

If you are, I think your problem is that manipulators are turned off, which is the default in XSI 4.0. So these icons in the viewports are only for display, and moving the object in x,y,z is done with the left (X), middle (Y) and right (Z) mouse button
To turn on manipulator, click Transform->Enable Transform Manipulator

Note that upgrading to XSI 4.2 is free for all XSI 4.0 users, it uses the same license, and is highlight recommended.

CoolCalb
01 January 2007, 08:50 PM
long shot: are you trying to move points on an envelope?

bunnyld
01 January 2007, 01:25 PM
bunnyld, are you a new user just starting with XSI 4.0?

If you are, I think your problem is that manipulators are turned off, which is the default in XSI 4.0. So these icons in the viewports are only for display, and moving the object in x,y,z is done with the left (X), middle (Y) and right (Z) mouse button
To turn on manipulator, click Transform->Enable Transform Manipulator

Note that upgrading to XSI 4.2 is free for all XSI 4.0 users, it uses the same license, and is highlight recommended.

'enable manipulators' was turned off.

I turn it on and it work fine now =)


thanks to all for the help !
again you help me with XSI. and i can move on to the next thing =).

CGTalk Moderation
01 January 2007, 01:25 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1